Bug 823820 - tgtadm: out of memory (255 LUNs and 8 targets)
tgtadm: out of memory (255 LUNs and 8 targets)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scsi-target-utils (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Andy Grover
Bruno Goncalves
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 05:01 EDT by Bruno Goncalves
Modified: 2017-12-06 05:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 05:15:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tries to create 255 luns in 8 targets (2.05 KB, application/x-shellscript)
2012-05-22 05:01 EDT, Bruno Goncalves
no flags Details

  None (edit)
Description Bruno Goncalves 2012-05-22 05:01:38 EDT
Created attachment 585970 [details]
tries to create 255 luns in 8 targets

Description of problem:
When trying to allocate 8 targets with 255 LUNs each, it failed with
out of memory error.

After it fails, the system still reports around 124Gb free

[root@storageqe-10 ~]# free -m
total used free shared buffers cached
Mem: 129027 2985 126042 0 57 395
-/+ buffers/cache: 2532 126495
Swap: 4095 0 4095

Version-Release number of selected component (if applicable):

rpm -q scsi-target-utils
scsi-target-utils-1.0.24-2.el6.x86_64

uname -r
2.6.32-272.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Get a server with 128GB (storageqe-10,11,12,13,14, for example)
2.Run the attached script

  
Actual results:
Starting SCSI target daemon: [ OK ]
tgtadm: out of memory
Command:
tgtadm -C 0 --lld iscsi --op new --mode logicalunit --tid 8 --lun 73 -b
/tmp/loop-disk-8-73
exited with code: 22.

Expected results:
tgtd should create all LUNs
Comment 1 RHEL Product and Program Management 2012-07-10 03:01:58 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 21:54:28 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 3 RHEL Product and Program Management 2012-09-07 01:23:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Jan Kurik 2017-12-06 05:15:38 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.