Bug 823824 - [RHEVM] [backend] [Setup Host Networks] user can assign duplicate IP on host
[RHEVM] [backend] [Setup Host Networks] user can assign duplicate IP on host
Status: CLOSED DUPLICATE of bug 839199
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: lpeer
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 05:08 EDT by Martin Pavlik
Modified: 2016-02-10 14:47 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 07:23:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (132.87 KB, application/x-gzip)
2012-05-22 05:19 EDT, Martin Pavlik
no flags Details
screenshot of duplicate IP in webadmin (142.43 KB, image/png)
2012-05-22 05:20 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-05-22 05:08:40 EDT
Description of problem:
It is possible to assign 2 interfaces on one host with same IP address

Version-Release number of selected component (if applicable):
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-9.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. create 2 logical networks
2. hosts-> your host-> Network Interfaces -> Setup Hosts Networks -> attach NICs to logical networks
3. assign interfaces with same IP

  
Actual results:
2 interfaces can be assigned with same IP

117: 1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN 
    link/ether d0:67:e5:f0:7f:30 brd ff:ff:ff:ff:ff:ff
    inet 10.34.67.106/27 brd 10.34.67.127 scope global 1
    inet6 fe80::d267:e5ff:fef0:7f30/64 scope link 
       valid_lft forever preferred_lft forever
119: 2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN 
    link/ether 90:e2:ba:04:28:b8 brd ff:ff:ff:ff:ff:ff
    inet 10.34.67.106/27 brd 10.34.67.127 scope global 2
    inet6 fe80::92e2:baff:fe04:28b8/64 scope link 
       valid_lft forever preferred_lft forever

Expected results:
it should be not possible to assign same IP on 2 interfaces for 1 host


Additional info:
Comment 1 Martin Pavlik 2012-05-22 05:19:20 EDT
Created attachment 585973 [details]
vdsm.log + engine.log
Comment 2 Martin Pavlik 2012-05-22 05:20:28 EDT
Created attachment 585974 [details]
screenshot of duplicate IP in webadmin
Comment 3 Martin Pavlik 2012-07-11 07:23:36 EDT

*** This bug has been marked as a duplicate of bug 839199 ***

Note You need to log in before you can comment on or make changes to this bug.