Bug 823868 - Rebalance and remove-brick does not obey quota usage limits
Rebalance and remove-brick does not obey quota usage limits
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
pre-release
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 06:56 EDT by shylesh
Modified: 2013-12-18 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: As 'rebalance' and 'remove-brick' are data migration operations, triggered from inside the filesystem itself, the quota usage limits are not enforced properly during that time. Consequence: During the time of rebalance/remove-brick it appears that the quota usage limits could have been not enforced as there is a chance that limits can be crossed because of temporary file creations by these processes. Workaround (if any): None. Ignore quota while these process are running. Result: Peace of mind :-)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-27 03:44:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: DP
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2012-05-22 06:56:23 EDT
Description of problem:
While rebalance or remove-brick is happening temporarily volume may violate quota limits.


In rebalance and remove-brick while migrating the data the file will not be truncated until it is completely written to the destionation, at this point in time there will be a chances of violating quota limits.

 suppose volume quota limit is 900MB and rebalancing a 500MB file, just before the completion of migration the total size might be 1GB but this will not be visible to the quota translator.
Comment 1 Amar Tumballi 2012-05-23 05:31:25 EDT
This is a known issue for now. Current version will have fixes by mentioning in documentation about the issue.
Comment 2 Amar Tumballi 2012-11-23 00:12:02 EST
updated doc-text field.
Comment 3 Amar Tumballi 2012-12-27 03:44:51 EST
Marked for Documentation pending. Will be closed as WONTFIX (as known issue field is updated)

Note You need to log in before you can comment on or make changes to this bug.