Bug 823869 - subscriptionmanager.SubscriptionManagerError:Runtime Error Batch update returned unexpected row count from update [0]
subscriptionmanager.SubscriptionManagerError:Runtime Error Batch update retur...
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: rc
: 1.X
Assigned To: Chris Duryee
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 06:58 EDT by Hui Wang
Modified: 2012-05-31 10:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 10:35:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hui Wang 2012-05-22 06:58:14 EDT
Description of problem:
 When run virt-who, and pause vm, it will report:
subscriptionmanager.SubscriptionManagerError: Runtime Error Batch update returned unexpected row count from update [0]; actual row count: 0; expected: 1 at org.hibernate.jdbc.Expectations$BasicExpectation.checkBatched:85

Version-Release number of selected component (if applicable):
virt-who-0.6-6.el6.noarch
subscription-manager-0.99.17-1.el6.x86_64
katello-headpin-0.2.6-4.el6_2.noarch
candlepin-0.6.2-1.el6_2.noarch
thumbslug-0.0.24-1.el6_2.noarch

How reproducible:

100%
Steps to Reproduce:
Step:
 1. Install rhevh on local host;
 2. Congigure network;
 3. Register to rhevm and sam; and add a guest on the rhevm
 4. Configure the virt-who.
     # vi /etc/sysconfig/virt-who
     VIRTWHO_BACKGROUND=1
     VIRTWHO_DEBUG=1
     VIRTWHO_INTERVAL=1
 5.Restart the virt-who service on terminal.
     # service virt-who restart

 7.Puase guest and check the terminal
 8.Resume guest and check the terminal

Puase guest
==============================
Virtual machine found: rhel63: 99f1d371-bbb5-483c-a3e3-ff19480210a7
Sending list of uuids: ['99f1d371-bbb5-483c-a3e3-ff19480210a7']
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 3350, in _dispatchDomainEventCallbacks
  File "/usr/share/virt-who/virt.py", line 85, in changed
  File "/usr/share/virt-who/subscriptionmanager.py", line 81, in sendVirtGuests
subscriptionmanager.SubscriptionManagerError: Runtime Error Batch update returned unexpected row count from update [0]; actual row count: 0; expected: 1 at org.hibernate.jdbc.Expectations$BasicExpectation.checkBatched:85
Actual results:


Expected results:
No the error info reported.

Additional info:
Comment 1 Chris Duryee 2012-05-29 10:10:48 EDT
Hui,

Can you send the stacktrace from candlepin when this happens?
Comment 2 Hui Wang 2012-05-29 22:03:31 EDT
(In reply to comment #1)
> Hui,
> 
> Can you send the stacktrace from candlepin when this happens?

Chris, 
Sorry, I can't provide the stacktrace immediately as the all the service PCs have been moved yesterday, and now we can't connect the env. I will provide the info ASAP if the network port opened.
Comment 3 Hui Wang 2012-05-31 01:59:19 EDT
Chris,

I verified the issue in the latest rhev-h(snapshot 5) and latest SAM-2012-05-25.1. The issue is no reproduce.

Version:
subscription-manager-0.99.19-1.el6.x86_64
virt-who-0.6-6.el6.noarch
katello-headpin-0.2.10-1.el6_2.noarch
katello-configure-0.3.7-1.el6_2.noarch
katello-headpin-all-0.2.10-1.el6_2.noarch
katello-common-0.3.2-1.el6_2.noarch
katello-cli-common-0.3.4-1.el6_2.noarch
katello-selinux-0.2.4-1.el6_2.noarch
katello-glue-candlepin-0.3.2-1.el6_2.noarch
katello-cli-headpin-0.2.2-1.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.1.5-1.el6_2.noarch
candlepin-tomcat6-0.6.5-1.el6_2.noarch
candlepin-0.6.5-1.el6_2.noarch
thumbslug-0.0.24-1.el6_2.noarch
Comment 4 Chris Duryee 2012-05-31 10:35:05 EDT
Glad to hear that the bug is not happening anymore. I am a little concerned though that the bug disappered, since we didn't change anything in candlepin that would have fixed this between 0.6.2 and 0.6.5.

I'll mark the bug as closed/notabug, but if you see the bug again, feel free to re-open.

Note You need to log in before you can comment on or make changes to this bug.