Bug 823921 - (htmldoc) broken dependency on fltk
(htmldoc) broken dependency on fltk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: soprano (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: alpha
: ---
Assigned To: Lukáš Tinkl
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 09:07 EDT by Bill Nottingham
Modified: 2015-07-13 13:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: virtuoso-opensource-6.1.5-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:52:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2012-05-22 09:07:15 EDT
Description of problem:

From the RHEL 7 0521 nightly:
package: htmldoc-1.8.27-18.el7.x86_64 from repoclosure-Server-optional.x86_64
  unresolved deps: 
     libfltk_images.so.1.3()(64bit)
     libfltk.so.1.3()(64bit)

Options are:

1) Fix htmldoc to not use FLTK
2) Fix virtuoso-opensource to not buildreq htmldoc
3) Fix soprano to not use virtuoso-opensource
4) something else?

I don't particularly care which, but we need to fix the broken dependency somehow.

Version-Release number of selected component (if applicable):

htmldoc-1.8.27-18.el7
Comment 1 Bill Nottingham 2012-06-14 09:30:26 EDT
Ping - can get we get some attention on this?
Comment 2 Ngo Than 2012-06-14 11:15:27 EDT
> 1) Fix htmldoc to not use FLTK
> 2) Fix virtuoso-opensource to not buildreq htmldoc
> 3) Fix soprano to not use virtuoso-opensource
> 4) something else?
> 
> I don't particularly care which, but we need to fix the broken dependency
> somehow.
> 
> Version-Release number of selected component (if applicable):
> 
> htmldoc-1.8.27-18.el7

htmdoc is only used to generate the online documents for virtuoso-opensource, the online documents is also available on http://docs.openlinksw.com/virtuoso/, i don't see any problem to drop the Build requirement on htmldoc in virtuoso-opensource.

I will build virtuoso-opensource without this BR on htmldoc.

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=4513675

virtuosobackend is needed in soprano, it cannot be dropped.


Than
Comment 3 Vladimir Benes 2012-06-19 11:06:35 EDT
-> VERIFIED
Comment 4 Bill Nottingham 2012-06-19 11:54:19 EDT
WHat is this verified against? I'm not seeing this build in the nightly.
Comment 5 Vladimir Benes 2012-06-19 12:01:22 EDT
(In reply to comment #4)
> WHat is this verified against? I'm not seeing this build in the nightly.

ahh.. wrong tree.. it works in Workstation .. but this was against server.. moving back to modified
Comment 7 Vladimir Benes 2012-12-14 04:43:49 EST
virtuoso-opensource-6.1.6-2.el7 now w/o htmldoc dependency
-> VERIFIED
Comment 9 Ludek Smid 2014-06-13 05:52:42 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.