Bug 823998 - logfile directive for subsystem breaks log to file
logfile directive for subsystem breaks log to file
Status: CLOSED UPSTREAM
Product: Corosync Cluster Engine
Classification: Community
Component: unknown (Show other bugs)
1.4
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Angus Salkeld
:
: 824007 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 10:44 EDT by Fabio Massimo Di Nitto
Modified: 2012-05-29 11:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 11:32:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Massimo Di Nitto 2012-05-22 10:44:45 EDT
Description of problem:

According to the old logging specification it should be possible to:

logging {
        # Log the source file and line where messages are being
        # generated. When in doubt, leave off. Potentially useful for
        # debugging.
        fileline: off
        # Log to standard error. When in doubt, set to no. Useful when
        # running in the foreground (when invoking "corosync -f")
        to_stderr: yes
        # Log to a log file. When set to "no", the "logfile" option
        # must not be set.
        to_logfile: yes
        logfile: /var/log/cluster/corosync.log
        # Log to the system log daemon. When in doubt, set to yes.
        to_syslog: yes
        # Log debug messages (very verbose). When in doubt, leave off.
        debug: off
        # Log messages with time stamps. When in doubt, set to on
        # (unless you are only logging to syslog, where double
        # timestamps can be annoying).
        timestamp: on
        logger_subsys {
                subsys: QUORUM
                debug: on
        }
        logger_subsys {
                subsys: VOTEQ
                debug: on
        }
        logger_subsys {
                subsys: QDISKD
                debug: on
                logfile: /var/log/cluster/test.log
        }
}

and have QDISKD subsystem use /var/log/cluster/test.log

The configuration is loaded, 2 files are created when starting up corosync:

[root@fedora-master-node2 cluster]# ls -las
total 8
4 drwxr-xr-x   2 root root 4096 May 22 16:39 .
4 drwxr-xr-x. 11 root root 4096 May 22 15:23 ..
0 -rw-r--r--   1 root root    0 May 22 16:39 corosync.log
0 -rw-r--r--   1 root root    0 May 22 16:39 test.log

but both files will always stay at 0 bytes, no matter how much logging is enabled.

Version-Release number of selected component (if applicable):

[root@fedora-master-node2 cluster]# rpm -q -i libqb
Name        : libqb
Version     : 0.13.0
Release     : 1.fc18

corosync built from git master

How reproducible:

always

Steps to Reproduce:
1. configure the above
2. start corosync
3.


Additional info:
Comment 2 Angus Salkeld 2012-05-28 20:45:32 EDT
Why do we have 2 bugs for this?

https://bugzilla.redhat.com/show_bug.cgi?id=824007
Comment 3 Fabio Massimo Di Nitto 2012-05-28 23:22:21 EDT
*** Bug 824007 has been marked as a duplicate of this bug. ***
Comment 4 Fabio Massimo Di Nitto 2012-05-28 23:23:23 EDT
(In reply to comment #2)
> Why do we have 2 bugs for this?
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=824007

bugzilla brain fart.. I am sure i only filed one.

Note You need to log in before you can comment on or make changes to this bug.