Bug 824095 - SELinux is preventing /usr/bin/rm from 'unlink' accesses on the file /home/mikhail/.ICAClient/CtxFlashCache/CacheFile.cache.
SELinux is preventing /usr/bin/rm from 'unlink' accesses on the file /home/mi...
Status: CLOSED DUPLICATE of bug 824099
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:1a058a44422ba1e372dd9f24d83...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 13:34 EDT by Mikhail
Modified: 2012-05-23 10:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-23 10:34:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2012-05-22 13:34:11 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.6-3.fc17.i686.PAE
time:           Вт. 22 мая 2012 23:33:57

description:
:SELinux is preventing /usr/bin/rm from 'unlink' accesses on the file /home/mikhail/.ICAClient/CtxFlashCache/CacheFile.cache.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rm should be allowed unlink access on the CacheFile.cache file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                /home/mikhail/.ICAClient/CtxFlashCache/CacheFile.c
:                              ache [ file ]
:Source                        rm
:Source Path                   /usr/bin/rm
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           coreutils-8.15-6.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.6-3.fc17.i686.PAE #1 SMP Wed May 16
:                              22:01:11 UTC 2012 i686 i686
:Alert Count                   2
:First Seen                    Вт. 22 мая 2012 23:32:51
:Last Seen                     Вт. 22 мая 2012 23:33:15
:Local ID                      8ad89039-f1de-4882-9428-f147133765d4
:
:Raw Audit Messages
:type=AVC msg=audit(1337707995.217:81): avc:  denied  { unlink } for  pid=7852 comm="rm" name="CacheFile.cache" dev="sdb1" ino=80741964 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1337707995.217:81): arch=i386 syscall=unlinkat per=400000 success=no exit=EACCES a0=ffffff9c a1=86188c0 a2=0 a3=0 items=0 ppid=7828 pid=7852 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=rm exe=/usr/bin/rm subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: rm,mozilla_plugin_t,user_home_t,file,unlink
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-05-23 10:34:07 EDT

*** This bug has been marked as a duplicate of bug 824099 ***

Note You need to log in before you can comment on or make changes to this bug.