Bug 824101 - Monitor Overview Page - Instance and Application numbers are not updated with page refresh
Monitor Overview Page - Instance and Application numbers are not updated with...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Linux
unspecified Severity high
: 1.0.1
: ---
Assigned To: Tzu-Mainn Chen
Ronelle Landy
: Triaged, ZStream
Depends On: 859451 810919
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 13:51 EDT by Chris Pelland
Modified: 2012-09-21 11:15 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The application and instance count on the “Monitor Overview” page did not update in real-time when a user deleted an application. This update adds real-time updates to the application and instance count in "Monitor Overview".
Story Points: ---
Clone Of: 810919
: 810919 (view as bug list)
Environment:
Last Closed: 2012-07-10 03:22:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
number of instances updated (218.89 KB, image/png)
2012-06-06 14:54 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Chris Pelland 2012-05-22 13:51:14 EDT
+++ This bug was initially created as a clone of Bug #810919 +++

Description of problem:
I have two browsers pointing at the same Conductor instance - both open to the Monitor Overview page: /conductor/pools. There are 101 instances running.

 - Using one browser, I stop the first of the 101 instances. After a few minutes I check the second browser. The instance is shown as stopped in the second browse - all good so far.

 - Now I go back to the first browser, to the conductor/deployments page and delete the second entry (deployment) and later the third. After a few minutes I check the second browser (still pointing at conductor/pools). This browser does not show the deleted instances but the *number* of Applications and *Instances* listed in the Cloud Resource Zone heading is not updated and still shows 101 Applications and 101 Instances. (see attached screenshots). 


Steps to Reproduce:
1. Open two browsers pointing at the same Conductor instance - both open to the Monitor Overview page: /conductor/pools
2. Using one browser, navigate to the conductor/deployments page
3. Delete one deployment
4. In the same browser navigate to the conductor/pools page - see that the deleted instance is no longer visible and the number of Instances and Applications has been updated (see screenshot 1)
5. Go to the second browser. See that the deleted instance is not showing but the number of Instances and Applications is not updated. (see screenshot 2)
  
rpms tested:

rpm -qa |grep aeolus
aeolus-conductor-daemons-0.8.7-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
Comment 1 Tzu-Mainn Chen 2012-05-23 09:50:34 EDT
Patch created:

https://fedorahosted.org/pipermail/aeolus-devel/2012-May/010487.html
Comment 2 Tzu-Mainn Chen 2012-05-23 09:55:17 EDT
Patch pushed to master:

commit 5c54d1dbc08a30ed4d5f14a7d628a156f3ca1141
BZ810919 mustach-ify pretty-view pool header so that instance/deployment counts are automatically updated
Comment 3 Tzu-Mainn Chen 2012-05-23 10:50:30 EDT
*** Bug 810919 has been marked as a duplicate of this bug. ***
Comment 4 Tzu-Mainn Chen 2012-05-29 14:23:16 EDT
1.0.1 patch pushed:

commit f21a43473643f252104eeab8f958915466648103
BZ824101 - product-only version of BZ810919; allows for real-time updating of monitor page's header and scoreboard
Comment 6 sachua 2012-06-05 23:48:25 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
If a user opens two browsers pointing at the "Monitor Overview" page of the same Condutor instance and deletes an application in a browser, the page header and scoreboard in the other browser fail to display the updated number of applications and instances. This update allows for real-time updating of "Monitor Overview" page header and scoreboard.
Comment 7 Dan Macpherson 2012-06-06 00:32:12 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-If a user opens two browsers pointing at the "Monitor Overview" page of the same Condutor instance and deletes an application in a browser, the page header and scoreboard in the other browser fail to display the updated number of applications and instances. This update allows for real-time updating of "Monitor Overview" page header and scoreboard.+The application and instance count on the “Monitor Overview” page did not update in real-time when a user deleted an application. This update adds real-time updates to the application and instance count in "Monitor Overview".
Comment 8 Ronelle Landy 2012-06-06 14:54:05 EDT
Verified that the number of instances and applications does update.

Opened two browsers both pointing at the same conductor (with four running instances) - one browser running FF and one running Chrome. Deleted an instance in the Chrome browser and saw the number of applications decrease (as well as the relevant instance disappear) in the FF browser.

Then stooped an instance in the Chrome browser and saw the number of instance decrease in the FF browser - plus the running color indicator turned to red.

See attached screenshot with taken from the FF browser.

rpms tested:

rpm -qa |grep aeolus
aeolus-conductor-daemons-0.8.27-1.el6_3.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.27-1.el6_3.noarch
aeolus-conductor-0.8.27-1.el6_3.noarch
rubygem-aeolus-cli-0.3.3-1.el6_3.noarch
aeolus-configure-2.5.7-1.el6_3.noarch
aeolus-conductor-doc-0.8.27-1.el6_3.noarch
Comment 9 Ronelle Landy 2012-06-06 14:54:51 EDT
Created attachment 589978 [details]
number of instances updated
Comment 11 errata-xmlrpc 2012-07-10 03:22:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1063.html

Note You need to log in before you can comment on or make changes to this bug.