Bug 824221 - SELinux is preventing /usr/sbin/cupsd from 'connectto' accesses on the unix_stream_socket /run/dbus/system_bus_socket.
SELinux is preventing /usr/sbin/cupsd from 'connectto' accesses on the unix_s...
Status: CLOSED DUPLICATE of bug 824224
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:bfced6eb66c9a89f684dab77fa3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 22:55 EDT by al morris
Modified: 2012-05-23 10:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-23 10:29:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description al morris 2012-05-22 22:55:18 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.6-3.fc16.x86_64
reason:         SELinux is preventing /usr/sbin/cupsd from 'connectto' accesses on the unix_stream_socket /run/dbus/system_bus_socket.
time:           Tue 22 May 2012 09:55:00 PM CDT

description:
:SELinux is preventing /usr/sbin/cupsd from 'connectto' accesses on the unix_stream_socket /run/dbus/system_bus_socket.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that cupsd should be allowed connectto access on the system_bus_socket unix_stream_socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep cupsd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
:Target Context                system_u:system_r:init_t:s0-s0:c0.c1023
:Target Objects                /run/dbus/system_bus_socket [ unix_stream_socket ]
:Source                        cupsd
:Source Path                   /usr/sbin/cupsd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           cups-1.5.2-9.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   minimum
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.6-3.fc16.x86_64 #1 SMP Wed May 16
:                              21:43:01 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 23 May 2012 02:20:25 AM CDT
:Last Seen                     Wed 23 May 2012 02:20:25 AM CDT
:Local ID                      d2310938-ade7-4945-89b2-54aeec5404a2
:
:Raw Audit Messages
:type=AVC msg=audit(1337757625.867:10): avc:  denied  { connectto } for  pid=1090 comm="cupsd" path="/run/dbus/system_bus_socket" scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:init_t:s0-s0:c0.c1023 tclass=unix_stream_socket
:
:
:type=SYSCALL msg=audit(1337757625.867:10): arch=x86_64 syscall=connect success=yes exit=0 a0=c a1=7fffa9768980 a2=21 a3=7fffa9768700 items=0 ppid=1 pid=1090 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=cupsd exe=/usr/sbin/cupsd subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: cupsd,cupsd_t,init_t,unix_stream_socket,connectto
:
:audit2allow
:
:#============= cupsd_t ==============
:allow cupsd_t init_t:unix_stream_socket connectto;
:
:audit2allow -R
:
:#============= cupsd_t ==============
:allow cupsd_t init_t:unix_stream_socket connectto;
:
Comment 1 Miroslav Grepl 2012-05-23 10:29:35 EDT

*** This bug has been marked as a duplicate of bug 824224 ***

Note You need to log in before you can comment on or make changes to this bug.