Bug 824225 - SELinux is preventing /sbin/rsyslogd from 'search' accesses on the directory /sys/fs/cgroup.
SELinux is preventing /sbin/rsyslogd from 'search' accesses on the directory ...
Status: CLOSED DUPLICATE of bug 824224
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:000667fcae3d2eed3aed9d9176b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 22:57 EDT by al morris
Modified: 2012-05-23 04:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-23 04:52:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description al morris 2012-05-22 22:57:21 EDT
libreport version: 2.0.8
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.6-3.fc16.x86_64
reason:         SELinux is preventing /sbin/rsyslogd from 'search' accesses on the directory /sys/fs/cgroup.
time:           Tue 22 May 2012 09:57:09 PM CDT

description:
:SELinux is preventing /sbin/rsyslogd from 'search' accesses on the directory /sys/fs/cgroup.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rsyslogd should be allowed search access on the cgroup directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rsyslogd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:syslogd_t:s0
:Target Context                system_u:object_r:cgroup_t:s0
:Target Objects                /sys/fs/cgroup [ dir ]
:Source                        rsyslogd
:Source Path                   /sbin/rsyslogd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           rsyslog-5.8.10-1.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   minimum
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.6-3.fc16.x86_64 #1 SMP Wed May 16
:                              21:43:01 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 23 May 2012 02:20:26 AM CDT
:Last Seen                     Wed 23 May 2012 02:20:26 AM CDT
:Local ID                      e52625d0-2a4f-455d-8090-3ffc6ee27238
:
:Raw Audit Messages
:type=AVC msg=audit(1337757626.482:41): avc:  denied  { search } for  pid=1202 comm="rsyslogd" name="/" dev="tmpfs" ino=14389 scontext=system_u:system_r:syslogd_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1337757626.482:41): arch=x86_64 syscall=lstat success=yes exit=0 a0=7f2223de36bc a1=7fffeebc74f0 a2=7fffeebc74f0 a3=9 items=0 ppid=1 pid=1202 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rsyslogd exe=/sbin/rsyslogd subj=system_u:system_r:syslogd_t:s0 key=(null)
:
:Hash: rsyslogd,syslogd_t,cgroup_t,dir,search
:
:audit2allow
:
:#============= syslogd_t ==============
:#!!!! This avc can be allowed using the boolean 'init_systemd'
:
:allow syslogd_t cgroup_t:dir search;
:
:audit2allow -R
:
:#============= syslogd_t ==============
:#!!!! This avc can be allowed using the boolean 'init_systemd'
:
:allow syslogd_t cgroup_t:dir search;
:
Comment 1 Miroslav Grepl 2012-05-23 04:52:49 EDT

*** This bug has been marked as a duplicate of bug 824224 ***

Note You need to log in before you can comment on or make changes to this bug.