Bug 824346 - rhc command line return 0 when encounter app creation failure due to non-vip user.
rhc command line return 0 when encounter app creation failure due to non-vip ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 06:18 EDT by Johnny Liu
Modified: 2015-05-14 21:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:26:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-05-23 06:18:59 EDT
Description of problem:
Try to create a medium app as a non-vip user, though fail to create it, the return value of command line is 0.

Maybe QE need the return value to decide if app creation is passed or failed.

Version-Release number of selected component (if applicable):
rhc-0.93.3-1.el6_2.noarch

How reproducible:
Always

Steps to Reproduce:
1. Try to create a medium app as a non-vip user.
$ rhc-create-app -a myapp -t php-5.3 -g medium -p xx
2.
3.
  
Actual results:
$ rhc-create-app -a myapp -t php-5.3 -g medium -p xx
Creating application: myapp in jialiu
Problem reported from server. Response code was 400.
Re-run with -d for more information.

RESULT:
Invalid Size: medium.  Must be: small.  Please contact support for access to additional sizes.

$ echo $?
0


Expected results:
It should return non-zero when encounter failure.

Additional info:
Comment 1 John (J5) Palmieri 2012-06-22 12:09:09 EDT
Looks like this has been fixed.
Comment 2 Meng Bo 2012-06-25 01:26:14 EDT
Checked on rhc-0.95.4, return code becomes 134 now.

Note You need to log in before you can comment on or make changes to this bug.