Bug 824362 - Katello-configure fails on F16 (when the machine is fast enough)
Katello-configure fails on F16 (when the machine is fast enough)
Status: CLOSED UPSTREAM
Product: Katello
Classification: Community
Component: Installer (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Zapletal
Katello QA List
:
Depends On: 824405
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 06:52 EDT by Lukas Zapletal
Modified: 2012-07-17 09:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 09:09:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2012-05-23 06:52:53 EDT
Description of problem:

err: /Stage[main]/Pulp::Config/Exec[migrate_pulp_db]/returns: change from notrun to 0 failed: pulp-migrate >/var/log/katello/katello-configure/pulp_migrate.log 2>&1 && touch /var/lib/pulp/init.flag returned 1 instead of one of [0] at /usr/share/katello/install/puppet/modules/pulp/manifests/config.pp:33

The issue is pulp-migration is just after service is started. We need to add a bit that will wait until mongodb accepts connections.
Comment 1 Lukas Zapletal 2012-05-23 08:34:48 EDT
4a07c90 Pushing sleep workaround.
Comment 3 Lukas Zapletal 2012-05-28 03:26:09 EDT
Did not help, the issue is in the mongodb preallocation. We need to add this additional Puppet step before we start mongo:

dd if=/dev/zero of=/var/lib/mongodb/journal/prealloc.0 bs=1M count=1K

(For three files - 0, 1 and 2. That's 3 GB by default.)

But only if /var/lib/mongodb/journal/j._0 does NOT exist. If it exist, mongod is already running - there is no need of explicit creation. Use "creates" for this.
Comment 4 Lukas Zapletal 2012-06-14 08:18:21 EDT
09f2c8e	

Merge pull request #152 from lzap/preallocation_824362
Comment 5 Bryan Kearney 2012-07-17 09:09:21 EDT
Moving all community bugs with fixes to closed.

Note You need to log in before you can comment on or make changes to this bug.