Bug 824435 - [RHEVM] | Edit management network | no verification on default GW field.
[RHEVM] | Edit management network | no verification on default GW field.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.0.3
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: lpeer
yeylon@redhat.com
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 09:04 EDT by Meni Yakove
Modified: 2016-04-18 02:59 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 04:55:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meni Yakove 2012-05-23 09:04:37 EDT
Description of problem:
Can set default GW that not in the network subnet

Example:
IP: 10.10.10.10
Netmask: 255.255.255.0
Gateway: 20.20.20.20

Version-Release number of selected component (if applicable):
rhevm-3.0.3_0001-3.el6.x86_64
Red Hat Enterprise Linux Server release 6.3 Beta (Santiago)

How reproducible:
Always

Steps to Reproduce:
1.Open edit management network
2.Set default GW that not in the network subnet
3.Apply
  
Actual results:
No error when apply.

Expected results:
Should be error when apply.
Comment 1 Martin Pavlik 2012-05-24 05:02:45 EDT
Bug still present in webadmin of 
oVirt Enterprise Virtualization Engine Manager Version: 3.1.0_0001-11.el6ev 

webadmin also does not complain when gateway is empty
Comment 3 lpeer 2012-08-06 04:55:19 EDT
since the default gateway on the management network is actually used as the host default gateway i don't see a reason to limit the gateway to the netmask of the management network.
I also don't see a reason to force the user to fill the gateway if he does not wish to do it.


I agree that we should separate the configuration of the host default gateway from the management network configuration. there is an open RFE for that BZ786052
Comment 4 Yaniv Kaul 2012-08-06 06:07:34 EDT
(In reply to comment #3)
> since the default gateway on the management network is actually used as the
> host default gateway i don't see a reason to limit the gateway to the
> netmask of the management network.

Apart from the fact that the default gateway, ALWAYS, has to be on the subnet of an interface.
(Unless a specific route has been set to it, which is the strangest thing one could do?).

> I also don't see a reason to force the user to fill the gateway if he does
> not wish to do it.

Indeed.

> 
> 
> I agree that we should separate the configuration of the host default
> gateway from the management network configuration. there is an open RFE for
> that BZ786052

Yes, especially if we (RHEL) support gateway per interface.
Comment 5 lpeer 2012-08-06 08:13:02 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > since the default gateway on the management network is actually used as the
> > host default gateway i don't see a reason to limit the gateway to the
> > netmask of the management network.
> 
> Apart from the fact that the default gateway, ALWAYS, has to be on the
> subnet of an interface.
> (Unless a specific route has been set to it, which is the strangest thing
> one could do?).
> 

But we don't want to force the default gateway to be on the management network subnet, it can be on the subnet of another network.
Comment 6 Yaniv Kaul 2012-08-06 08:22:41 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > since the default gateway on the management network is actually used as the
> > > host default gateway i don't see a reason to limit the gateway to the
> > > netmask of the management network.
> > 
> > Apart from the fact that the default gateway, ALWAYS, has to be on the
> > subnet of an interface.
> > (Unless a specific route has been set to it, which is the strangest thing
> > one could do?).
> > 
> 
> But we don't want to force the default gateway to be on the management
> network subnet, it can be on the subnet of another network.

so it should be a property of the host, not of a network.
Comment 7 lpeer 2012-08-07 03:22:54 EDT
> so it should be a property of the host, not of a network.

true, see RFE for that BZ786052

Note You need to log in before you can comment on or make changes to this bug.