Bug 824438 - SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'add_name' accesses on the directory socket-9666-1526706912.
SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'add_name'...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:60f9768b0c836abbd075d514f4d...
:
: 827892 828017 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 09:11 EDT by forum-dante
Modified: 2012-06-04 07:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-03 19:31:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description forum-dante 2012-05-23 09:11:51 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.6-3.fc17.x86_64
time:           Mi 23 Mai 2012 15:05:49 CEST

description:
:SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'add_name' accesses on the directory socket-9666-1526706912.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If sie denken, dass plugin-container standardmässig erlaubt sein sollte, add_name Zugriff auf socket-9666-1526706912 directory zu erhalten.
:Then sie sollten dies als Fehler melden.
:Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
:Do
:zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                system_u:object_r:xdm_tmp_t:s0
:Target Objects                socket-9666-1526706912 [ dir ]
:Source                        plugin-containe
:Source Path                   /usr/lib64/xulrunner-2/plugin-container
:Port                          <Unbekannt>
:Host                          (removed)
:Source RPM Packages           xulrunner-12.0-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.6-3.fc17.x86_64 #1 SMP
:                              Wed May 16 21:21:18 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Di 22 Mai 2012 22:43:27 CEST
:Last Seen                     Di 22 Mai 2012 22:43:27 CEST
:Local ID                      a0284b77-d4cb-47e4-b0b6-bd576e00b161
:
:Raw Audit Messages
:type=AVC msg=audit(1337719407.814:361): avc:  denied  { add_name } for  pid=9666 comm="plugin-containe" name="socket-9666-1526706912" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_tmp_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1337719407.814:361): arch=x86_64 syscall=bind success=no exit=EACCES a0=10 a1=7fff8a856450 a2=25 a3=7fff8a856140 items=0 ppid=9616 pid=9666 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=plugin-containe exe=/usr/lib64/xulrunner-2/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: plugin-containe,mozilla_plugin_t,xdm_tmp_t,dir,add_name
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Daniel Walsh 2012-05-24 10:11:01 EDT
Any idea what plugin caused this?
Comment 2 Daniel Walsh 2012-05-24 10:14:58 EDT
Fixed in selinux-policy-3.10.0-127.fc17
Comment 3 forum-dante 2012-05-24 10:52:58 EDT
Thanks for fixing I think this is the plugin-container from Firefox.

cheers,
elias
Comment 4 Daniel Walsh 2012-05-24 12:11:01 EDT
Yes, but it is a particular plugin that is trying to create a socket in the xdm_tmp_t directory under /tmp.

 ls -lZ /tmp/ | grep xdm
drwxrwxrwt. gdm    gdm    system_u:object_r:xdm_tmp_t:s0   at-spi2
drwx------. gdm    gdm    system_u:object_r:xdm_tmp_t:s0   pulse-lIYcGBkD27q1
Comment 5 forum-dante 2012-05-24 13:18:18 EDT
Thanks for the info. Note: This seems to bee a basic problem because this was a fresh install of FD17. No additional plug-ins installed yet. After using the policy to give write-access I got the message that the policy will downgrade from 27 to 26.

cheers,
elias
Comment 6 Daniel Walsh 2012-05-24 19:17:05 EDT
Ok, You can ignore the 27-26 problem.  This will be fixed when the kernels get in synch with the policy.
Comment 7 Fedora Update System 2012-05-31 02:27:19 EDT
selinux-policy-3.10.0-128.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-128.fc17
Comment 8 Fedora Update System 2012-06-01 13:09:18 EDT
Package selinux-policy-3.10.0-128.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-128.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8720/selinux-policy-3.10.0-128.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-06-03 19:31:46 EDT
selinux-policy-3.10.0-128.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Miroslav Grepl 2012-06-04 03:16:45 EDT
*** Bug 828017 has been marked as a duplicate of this bug. ***
Comment 11 Miroslav Grepl 2012-06-04 07:13:13 EDT
*** Bug 827892 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.