Bug 824472 - writes fail on nfs mount
writes fail on nfs mount
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: rpc (Show other bugs)
mainline
All All
high Severity urgent
: ---
: ---
Assigned To: Amar Tumballi
Sachidananda Urs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 10:35 EDT by Rajesh
Modified: 2013-12-18 19:08 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 08:00:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rajesh 2012-05-23 10:35:36 EDT
Description of problem:
dbench, bonnie++  or any other writes on an nfs mount fail with the following logs:
[2012-05-23 19:05:59.953881] E [nfs3.c:2279:nfs3svc_write] 0-nfs-nfsv3: Error decoding args
[2012-05-23 19:05:59.958012] E [nfs3.c:2279:nfs3svc_write] 0-nfs-nfsv3: Error decoding args
[2012-05-23 19:05:59.959054] E [nfs3.c:2279:nfs3svc_write] 0-nfs-nfsv3: Error decoding args
.
.
.

Version-Release number of selected component (if applicable): mainline


How reproducible: always


Steps to Reproduce:
1. mount any gluster volume via nfs
2. try to writing on the mount point
Comment 1 Saurabh 2012-05-24 02:53:35 EDT
my setup is sync'ed to this commit id
commit b86436da7e0de47282c46cd14989e4cbaad0501d

and I executed iozone and untar of linux, the nfs.log does not complain about the issue mentioned above.

Are you finding the on the master? as my setup is checked out for release-3.3
Comment 2 Amar Tumballi 2012-05-24 03:18:26 EDT
Saurabh, this happens only on master. Caused by one of my patch, I am looking into this issue.
Comment 3 Sachidananda Urs 2012-05-31 11:24:54 EDT
Amar is there a patch or something you sent that I can cross check?
Comment 4 Amar Tumballi 2012-06-01 02:53:59 EDT
the bug fix is only in upstream, not in release-3.3. Hence moving it out of the ON_QA, and setting MODIFIED (as a standard practice @ Red Hat)
Comment 5 Amar Tumballi 2012-12-18 06:23:24 EST
Rajesh/Saurabh, I am moving it back to assigned. But can you guys take a resolution? because I see that this bug doesn't have a patch to fix any issues, also comment #1 says its not happening anymore. Please take a appropriate call.
Comment 6 Rajesh 2012-12-18 08:00:39 EST
works in the latest git head

Note You need to log in before you can comment on or make changes to this bug.