Bug 824559 - Protocol spec without prior Class and Subclass spec at line 4297
Protocol spec without prior Class and Subclass spec at line 4297
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hwdata (Show other bugs)
5.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: Karsten Hopp
Aleš Mareček
: EasyFix, Patch, Regression
Depends On:
Blocks: 743405
  Show dependency treegraph
 
Reported: 2012-05-23 14:07 EDT by Jeff Bastian
Modified: 2013-01-08 02:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:44:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to remove Samsung Galaxy Ace device from usb.ids (510 bytes, patch)
2012-05-23 14:52 EDT, Jeff Bastian
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 128093 None None None 2012-06-08 15:22:41 EDT

  None (edit)
Description Jeff Bastian 2012-05-23 14:07:29 EDT
Description of problem:
lsusb reports an error:
Protocol spec without prior Class and Subclass spec at line 4297

Line 4297 of /usr/share/hwdata/usb.ids contains:
                04e8 689e  GT-S5830 (Samsung Galaxy Ace)


Version-Release number of selected component (if applicable):
hwdata-0.213.26-1.el5.noarch

How reproducible:
every time

Steps to Reproduce:
1. lsusb
  
Actual results:
Protocol spec without prior Class and Subclass spec at line 4297

Expected results:
no error

Additional info:
Comment 1 Jeff Bastian 2012-05-23 14:10:39 EDT
The error does not happen with hwdata-0.213.25-1.el5 so it's a recent change that introduced the bug.
Comment 2 Jeff Bastian 2012-05-23 14:52:03 EDT
Created attachment 586430 [details]
patch to remove Samsung Galaxy Ace device from usb.ids

The RHEL 6 usb.ids file does not have the offending line, so I think the easiest fix is to simply remove that line.
Comment 10 errata-xmlrpc 2013-01-08 02:44:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0101.html

Note You need to log in before you can comment on or make changes to this bug.