Bug 82463 - The Installler had quit due to an error with video and monitor.
The Installler had quit due to an error with video and monitor.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-22 09:33 EST by Scott Fletcher
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-29 17:00:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete StackTrace of the dump file (78.42 KB, text/plain)
2003-01-22 09:44 EST, Scott Fletcher
no flags Details

  None (edit)
Description Scott Fletcher 2003-01-22 09:33:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030121

Description of problem:
After correctly detecting the video card and monitor, the installer is unable to
display the graphic correctly (corrupt displaying) during installation and it
terminated the installing process with an error.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot up the machine with Red Hat installer
2. Press 'Enter' at the 'Linux: ' prompt for default installation
3. Go through step-by-step in question and answering
4. Once done, Red Hat installer attempt to switch to graphic mode.
5. Corrupted graphic occured and installer quit.
6. Rebooted the machine and start over with the Red Hat installer
7. Entered 'linux noprobe' at the 'Linux: ' prompt
8. Went through step-by-step in question and answering
9. When getting to the part about video card and monitor, carefully
    entered the data and click on the 'test' button in text mode to
    determine the correct resolution # as well as # of color.
10. The corrupted display was shown and the installer then dump the 
     stack file and then quit.
    

Actual Results:  When the graphic mode was displayed, it is all corrupted. 
Looked a lot like the static on older tv when the station go off air.  It is all
in different color and a couple of lines in vertical along with some horizontal
line.  There's a lot of more static spots all over than lines.

Expected Results:  Should be able to display the correct arrangement of images
in dots and colors, just like tv as an example.

Additional info:

There is one other error that are related to this.  In text mode, before going
to the graphic mode, when the configuration for video card and graphic is made.
 It sometime displayed an one line error message but can not write it down
because it is displayed behind the menu and buttons.
Comment 1 Scott Fletcher 2003-01-22 09:41:37 EST
One quick question!  Help me out with the Hardware setting at the top, it said
'i586'.  If you know the Hardware setting for a machine with a Pentium 4 then
feel free to correct it for me.  Thanks!!!


Video card is built-in to the motherboard, the video setting from Red Hat is
'VESA generic' and the monitor setting is 'Radius RADS-5'.  I'll let the stack
trace explain it all to you.


I'm going to include a very short stack track here and I'll include the whole
stack track in an file attachment.


--clip--
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 694, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 425, in run
    rc = apply(win, (self.screen, ) + args)
  File "/usr/lib/anaconda/textw/xconfig_text.py", line 450, in __call__
    monlabel = Textbox(20, 1, (selMonitor[0]))
TypeError: unsubscriptable object

Local variables in innermost frame:
selMonitorName: RDS1559
videogrid: <snack.Grid instance at 0xa709444>
monitor: monName: RDS1559
monID: RDS1559
fbmonSect: 
monHoriz: 31-62
monVert: 56-75
physicalWidth: 0
physicalHeight: 0

bb: <snack.ButtonBar instance at 0xa8dd34c>
title: DDC Probed Monitor - Radius Rad-5
text: Select the monitor for your system.  Use the 'Default' button to reset to
the probed values.
screen: <snack.SnackScreen instance at 0x820ac84>
label: <snack.Label instance at 0xaa3a5d4>
selMonitor: None
toplevel: <snack.GridFormHelp instance at 0x92f0584>
mon: ('Siemens Nixdorf MCM2102', 'siemens4', '50-160', '30-82')
xconfig: <xf86config.XF86Config instance at 0x815566c>
self: <xconfig_text.MonitorWindow instance at 0x92baebc>
man: DDC Probed Monitor - Radius Rad-5
--clip--

Final question, let me know on what my next step should be.....  Thanks!
Comment 2 Scott Fletcher 2003-01-22 09:44:46 EST
Created attachment 89524 [details]
Complete StackTrace of the dump file

Amending the file attachment of a complete StackTrace of the dump file....
Comment 3 Michael Fulbright 2003-01-22 12:57:27 EST
I believe this issue has been resolved in our latest beta.

To workaround the problem in 8.0 just go to the monitor screen and pick a
'Generic Monitor ...' that is close to what you have, instead of entering the
values by hand. You can use redhat-config-xfree86 after you reboot to change
this setting if it doesnt work.
Comment 4 Scott Fletcher 2003-01-22 21:52:05 EST
I tried it again twice today using the 'boot: linux noprobe'.  I tried any 
generic monitor but it only gave me two result, one with a frequency out of 
range message and the other with all black screen.  I'm going to take a break 
and will try it again a couple of time on this weekend.  I mean, I work 40 
hours a week you know...  So, good luck with Red Hat...  If I can't get it to 
work then I'll try version 7.3 or whatever was the latest version was before 
8.0 ...
Comment 5 Scott Fletcher 2003-01-27 21:51:41 EST
Found hte problem.  The VGA driver doesn't match to the video card on the 
machine.  I was wrong on saying that Red Hat correctly use the VESA generic 
driver because I'm not sure if this is the right one now.  The video card in 
the machine use hte SIS 650 chipset, so it is a XFree86 issue.  There is no 
available VGA driver for this and XFree86 hasn't released a newer version for a 
year now.  May will have to put the machine back into the box and wait for 6 
months or 1 year, who know....  THis is now not a Red Hat issue, it's a XFree86 
issue.  Thanks!!!!
Comment 6 Jeremy Katz 2003-01-29 17:00:50 EST
And as Mike said, the traceback is fixed in our current codebase

Note You need to log in before you can comment on or make changes to this bug.