Bug 824665 - Unable to install system updates / packages that require accepting a security signature
Summary: Unable to install system updates / packages that require accepting a security...
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 17
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-23 23:08 UTC by Andrew
Modified: 2012-07-11 19:00 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-07-11 19:00:35 UTC


Attachments (Terms of Use)
Security Signature prompt #1 (467.37 KB, image/jpeg)
2012-05-23 23:08 UTC, Andrew
no flags Details
Security Signature approval prompt #2 (499.69 KB, image/jpeg)
2012-05-23 23:09 UTC, Andrew
no flags Details
Error after approving Security Signature (439.67 KB, image/jpeg)
2012-05-23 23:10 UTC, Andrew
no flags Details

Description Andrew 2012-05-23 23:08:59 UTC
Created attachment 586479 [details]
Security Signature prompt #1

[[[Originally bug823384, couldn't make significant revisions or delete prior. Sorry for the inconvenience]]]

Description of problem:

When attempting to install a package from an official Fedore 17 repo that requires accepting a security signature, the following error occurs upon approving the package.

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._pk_5ftransaction_5ferror.Code14: Invalid input passed to daemon: char '<' in text!

Enclosed are screenshots leading up to the error and the error itself.


Version-Release number of selected component (if applicable):

packagekit 3.4.0
gpk-update-viewer

How reproducible:

Always


Steps to Reproduce:
1. Log into Gnome
2. Enable online repos if they're not already enabled
5. Activities -> Software Update -> Install Updates
6. Accept the package's security signature (As seen in During and 2.jpg)
7. Observe failure (as shown in After.jpg)
  
Actual results:
Package fails to install / update

Expected results:

Packages / updates should install successfully

Additional info:

Sorry if I'm reporting an issue that may have already been addressed but I am unable to update the system at all. Please advise.

Comment 1 Andrew 2012-05-23 23:09:53 UTC
Created attachment 586480 [details]
Security Signature approval prompt #2

Comment 2 Andrew 2012-05-23 23:10:56 UTC
Created attachment 586481 [details]
Error after approving Security Signature

Error that occurs after approving package's security signature

Comment 3 Andrew 2012-07-11 19:00:35 UTC
Closing now as "Works for me" since this bug only seems to affect the beta and does not occur in the official release... thanks for completely ignoring this one guys... :-/


Note You need to log in before you can comment on or make changes to this bug.