Bug 824672 - augeas: qemu.conf - Adding spice_tls and spice_tls_x509_cert_dir
augeas: qemu.conf - Adding spice_tls and spice_tls_x509_cert_dir
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
17
All Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Laine Stump
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 19:58 EDT by Douglas Schilling Landgraf
Modified: 2012-06-30 18:05 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-30 18:05:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (598 bytes, patch)
2012-05-23 20:00 EDT, Douglas Schilling Landgraf
no flags Details | Diff

  None (edit)
Description Douglas Schilling Landgraf 2012-05-23 19:58:52 EDT
Description of problem:

If vdsm is installed and configured in Fedora 17, we add the following items into qemu.conf:

spice_tls=1
spice_tls_x509_cert_dir="/etc/pki/vdsm/libvirt-spice"

However, after this changes, augtool cannot identify qemu.conf anymore.

# augtool 
augtool> print /files/etc/libvirt/
lxc.conf/           qemu-sanlock.conf/  


Here a suggestion patch to libvirtd_qemu lens:

$ git diff
diff --git a/src/qemu/libvirtd_qemu.aug b/src/qemu/libvirtd_qemu.aug
index f6cec1f..49587bf 100644
--- a/src/qemu/libvirtd_qemu.aug
+++ b/src/qemu/libvirtd_qemu.aug
@@ -35,6 +35,8 @@ module Libvirtd_qemu =
                  | str_entry "security_driver"
                  | bool_entry "security_default_confined"
                  | bool_entry "security_require_confined"
+                 | bool_entry "spice_tls"
+                 | str_entry  "spice_tls_x509_cert_dir"
                  | str_entry "user"
                  | str_entry "group"
                  | bool_entry "dynamic_ownership"

Applying the above patch, it works nice.
Comment 1 Douglas Schilling Landgraf 2012-05-23 20:00:16 EDT
Created attachment 586488 [details]
patch
Comment 3 Eric Blake 2012-05-24 08:20:31 EDT
Can you please also post this patch upstream, at libvir-list@redhat.com, so that it will get reviewed faster?
Comment 4 Douglas Schilling Landgraf 2012-05-24 14:15:18 EDT
Hi Eric,

Here the patch upstream:
http://www.redhat.com/archives/libvir-list/2012-May/msg01190.html
Comment 5 Daniel Berrange 2012-05-25 08:46:53 EDT
Fixed some further bugs & improved testing to avoid future regressions with this

https://www.redhat.com/archives/libvir-list/2012-May/msg01211.html
Comment 6 Fedora Update System 2012-06-19 11:56:33 EDT
libvirt-0.9.11.4-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libvirt-0.9.11.4-2.fc17
Comment 7 Fedora Update System 2012-06-20 15:24:15 EDT
Package libvirt-0.9.11.4-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-0.9.11.4-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9708/libvirt-0.9.11.4-2.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-06-28 10:06:05 EDT
libvirt-0.9.11.4-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libvirt-0.9.11.4-3.fc17
Comment 9 Fedora Update System 2012-06-30 18:05:21 EDT
libvirt-0.9.11.4-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.