Bug 824946 - A user reported that he's seeing both MySQL and MongoDB cartridges installed when viewing the Web Console's "add cartridge" page.
A user reported that he's seeing both MySQL and MongoDB cartridges installed ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Lili Nader
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 12:47 EDT by Nam Duong
Modified: 2015-05-14 20:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:58:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-05-24 12:47:19 EDT
Description of problem:
This came through the openshift@redhat.com mailing list:

On the "ADD A CARTRIDGE" page I see "MySQL Database 5.1" but when I look at the list of cartridges (the view where I can delete my app), I only see "Python 2.6" and "mongodb-2.0".


Attached are some screenshots which show that "4-Add cartridge page.png" has MySQL and MongoDB cartridges selected, yet his "rhc domain show" command shows otherwise:
User Info
=========
Namespace: bbigras
RHLogin: bigras.bruno@gmail.com


Application Info
================
jenkins
Framework: jenkins-1.4
Creation: 2012-05-23T15:06:02-04:00
UUID: ec1c893ada7547f0ad691f897f2f9607
Git URL: ssh://ec1c893ada7547f0ad691f897f2f9607@jenkins-bbigras.rhcloud.com/~/git/jenkins.git/
Public URL: http://jenkins-bbigras.rhcloud.com/

Embedded:
None

tv
Framework: python-2.6
Creation: 2012-05-24T02:23:38-04:00
UUID: ff9eff9d437146c3aee7b5d27f4479a0
Git URL: ssh://ff9eff9d437146c3aee7b5d27f4479a0@tv-bbigras.rhcloud.com/~/git/tv.git/
Public URL: http://tv-bbigras.rhcloud.com/

Embedded:
mongodb-2.0 - Connection URL: mongodb://127.3.202.129:27017/
rockmongo-1.1 - URL: https://tv-bbigras.rhcloud.com/rockmongo/



His steps to reproduce:
It may be possible that I still see "MySQL Database 5.1" because I had it installed in an app with the same name that I destroyed earlier.
Comment 1 Clayton Coleman 2012-05-24 19:57:01 EDT
Do we have a cache of cartridge info per app that is being called?  The UI is just calling /cartridges.json and formatting the output
Comment 2 Lili Nader 2012-05-30 16:51:01 EDT
works for me
Comment 3 Peter Ruan 2012-05-31 18:39:30 EDT
Can't reproduce on QA either.

Note You need to log in before you can comment on or make changes to this bug.