Bug 825036 - UV2 IO: Need to be able to support more cards with I/O BARs
UV2 IO: Need to be able to support more cards with I/O BARs
Status: CLOSED DUPLICATE of bug 859966
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.4
x86_64 Linux
high Severity high
: rc
: 6.4
Assigned To: George Beshers
Red Hat Kernel QE team
: FutureFeature
Depends On:
Blocks: 746047 790971 846704
  Show dependency treegraph
 
Reported: 2012-05-24 17:30 EDT by George Beshers
Modified: 2012-11-08 13:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 13:01:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upstream patch adding nobar cmdline argument (3.72 KB, patch)
2012-05-24 17:30 EDT, George Beshers
no flags Details | Diff

  None (edit)
Description George Beshers 2012-05-24 17:30:53 EDT
Created attachment 586713 [details]
Upstream patch adding nobar cmdline argument

Description of problem:

commit 7bd1c365fd124624191d49dcc1eb9759d6017ec3
Author: Mike Habeck <habeck@sgi.com>
Date:   Wed May 12 11:14:32 2010 -0700

    x86/PCI: Add option to not assign BAR's if not already assigned
    
    The Linux kernel assigns BARs that a BIOS did not assign, most likely
    to handle broken BIOSes that didn't enumerate the devices correctly.
    On UV the BIOS purposely doesn't assign I/O BARs for certain devices/
    drivers we know don't use them (examples, LSI SAS, Qlogic FC, ...).
    We purposely don't assign these I/O BARs because I/O Space is a very
    limited resource.  There is only 64k of I/O Space, and in a PCIe
    topology that space gets divided up into 4k chucks (this is due to
    the fact that a pci-to-pci bridge's I/O decoder is aligned at 4k)...
    Thus a system can have at most 16 cards with I/O BARs: (64k / 4k = 16)
    
    SGI needs to scale to >16 devices with I/O BARs.  So by not assigning
    I/O BARs on devices we know don't use them, we can do that (iff the
    kernel doesn't go and assign these BARs that the BIOS purposely didn't
    assign).
    
    This patch will not assign a resource to a device BAR if that BAR was
    not assigned by the BIOS, and the kernel cmdline option 'pci=nobar'
    was specified.   This patch is closely modeled after the 'pci=norom'
    option that currently exists in the tree.
    
    Signed-off-by: Mike Habeck <habeck@sgi.com>
    Signed-off-by: Mike Travis <travis@sgi.com>
    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2012-07-10 03:40:20 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 19:43:53 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 George Beshers 2012-11-08 13:01:43 EST
This BZ was fixed in the patchset for BZ#859966
because of a dependency.

*** This bug has been marked as a duplicate of bug 859966 ***

Note You need to log in before you can comment on or make changes to this bug.