Bug 825085 - Breadcrumb trail doesn't display correctly in REST API pages if not served from server root URL
Breadcrumb trail doesn't display correctly in REST API pages if not served fr...
Status: CLOSED NEXTRELEASE
Product: PulpDist
Classification: Community
Component: Web App (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nick Coghlan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 01:05 EDT by Nick Coghlan
Modified: 2012-05-25 01:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-25 01:50:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Coghlan 2012-05-25 01:05:20 EDT
If served from mod_wsgi and WSGIScriptAlias is set to something other than "/", the breadcrumb trail isn't displayed properly in the REST API browser pages.

This is due to a bug in the djangorestframework upstream: https://github.com/tomchristie/django-rest-framework/pull/211

It should be possible to workaround this by creating the breadcrumbs list directly in the PulpDist REST API views.
Comment 1 Nick Coghlan 2012-05-25 01:50:16 EDT
Fixed for 0.0.16

Note You need to log in before you can comment on or make changes to this bug.