Bug 825124 - get "dirname: extra operand" error when run "rhc-idler -l" command on instance
get "dirname: extra operand" error when run "rhc-idler -l" command on instance
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Regression, Triaged
: 825214 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 04:00 EDT by Meng Bo
Modified: 2015-05-14 18:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhc-node-0.93.9+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:58:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-05-25 04:00:44 EDT
Description of problem:
[root@ip-10-119-2-149 ~]# rhc-idler -u e5b131262e2645268d9a016501b66f75
Stopping e5b131262e2645268d9a016501b66f75...
    php1_ctl.sh                                            [  OK  ]

[root@ip-10-119-2-149 ~]# rhc-idler -l
dirname: extra operand `/etc/httpd/conf.d/stickshift/e5b131262e2645268d9a016501b66f75_bmengdev_php1/00000_default.conf'
Try `dirname --help' for more information.
dirname: extra operand `/etc/httpd/conf.d/stickshift/e5b131262e2645268d9a016501b66f75_bmengdev_php1/00000_default.conf'
Try `dirname --help' for more information.


Version-Release number of selected component (if applicable):
devenv_1802

How reproducible:
always

Steps to Reproduce:
1.create app from client side
2.login to instance and try to idle the app via rhc-idler
rhc-idler -u xxxxxx
3.show the idle app list
rhc-idler -l
  
Actual results:
get "dirname: extra operand `/etc/httpd/conf.d/stickshift/e5b131262e2645268d9a016501b66f75_bmengdev_php1/00000_default.conf'" error when running the rhc-idler -l

Expected results:
idle apps should be listed successfully.

Additional info:
Comment 1 Johnny Liu 2012-05-25 07:30:57 EDT
In /usr/bin/rhc-idler:
<--snip-->
function is_idled {
    appid=$1

    HTTP_DIR=`dirname "/etc/httpd/conf.d/stickshift/${uuid}"*/00000_default.conf`

<--snip-->

"appid" and "uuid" should keep consistent.
Comment 2 Johnny Liu 2012-05-25 07:31:48 EDT
*** Bug 825214 has been marked as a duplicate of this bug. ***
Comment 3 Rob Millner 2012-05-25 20:08:05 EDT
Commit f789d9d in li.
Comment 4 Johnny Liu 2012-05-28 03:03:24 EDT
Verified this bug with devenv_1806, and PASS.

# rhc-idler -l
77b51f9924504afc8605cec26c2034f1 is idled
2967a176b67140ecbad7bd9b328010de is idled

Note You need to log in before you can comment on or make changes to this bug.