Bug 825205 - Horde PHP alert of old code
Horde PHP alert of old code
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: horde (Show other bugs)
16
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 07:08 EDT by dev002
Modified: 2012-06-14 11:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 11:25:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dev002 2012-05-25 07:08:39 EDT
Description of problem:
PHP alert of old code

 Deprecated: Assigning the return value of new by reference is deprecated in /usr/share/horde/lib/Horde/MIME/Message.php on line 68
Deprecated: Assigning the return value of new by reference is deprecated in /usr/share/horde/lib/Horde/MIME/Message.php on line 335
Deprecated: Assigning the return value of new by reference is deprecated in /usr/share/horde/lib/Horde/MIME.php on line 279
Deprecated: Assigning the return value of new by reference is deprecated in /usr/share/horde/lib/Horde/MIME/Headers.php on line 501
 Deprecated: Assigning the return value of new by reference is deprecated in /usr/share/horde/lib/Horde/MIME/Message.php on line 68
Deprecated: Assigning the return value of new by reference is deprecated in /usr/share/horde/lib/Horde/MIME/Message.php on line 335
Deprecated: Assigning the return value of new by reference is deprecated in /usr/share/horde/lib/Horde/MIME.php on line 279
Deprecated: Assigning the return value of new by reference is deprecated in /usr/share/horde/lib/Horde/MIME/Headers.php on line 501

Version-Release number of selected component (if applicable):


How reproducible:
use horde lib

Steps to Reproduce:
1.use
2.warning
3.some code could not work, reason warnings of PHP about Horde
  
Actual results:
old style code

Expected results:
PHP 5.3 compatible code

Additional info:
Comment 1 Nick Bebout 2012-06-14 11:25:55 EDT
We are working on packaging Horde4.  We are no longer updating the Horde 3 packages.

Note You need to log in before you can comment on or make changes to this bug.