Bug 825214 - incorrect variable is using in is_idled function.
incorrect variable is using in is_idled function.
Status: CLOSED DUPLICATE of bug 825124
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 07:21 EDT by Johnny Liu
Modified: 2015-05-14 18:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-25 07:31:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-05-25 07:21:43 EDT
Description of problem:
In /usr/bin/rhc-idler:
<--snip-->
function is_idled {
    appid=$1

    HTTP_DIR=`dirname "/etc/httpd/conf.d/stickshift/${uuid}"*/00000_default.conf`

<--snip-->

"appid" and "uuid" should keep consistent.




Version-Release number of selected component (if applicable):
devenv_1802

How reproducible:
Always

Steps to Reproduce:
1. Create app, then idle it.
2. Run "rhc-idler -l" to check the idled app list.
3. 
  
Actual results:
# rhc-idler -l
dirname: extra operand `/etc/httpd/conf.d/stickshift/aa95127730c54af08225df07a380c359_jialiu_jenkins/00000_default.conf'
Try `dirname --help' for more information.
dirname: extra operand `/etc/httpd/conf.d/stickshift/aa95127730c54af08225df07a380c359_jialiu_jenkins/00000_default.conf'
Try `dirname --help' for more information.


Expected results:
rhc-idler should work fine.

Additional info:
Comment 1 Johnny Liu 2012-05-25 07:31:48 EDT

*** This bug has been marked as a duplicate of bug 825124 ***

Note You need to log in before you can comment on or make changes to this bug.