Bug 825218 - rhc-admin-move help message need to be updated
rhc-admin-move help message need to be updated
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 07:43 EDT by Johnny Liu
Modified: 2015-05-14 21:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 13:58:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2012-05-25 07:43:06 EDT
Description of problem:
# rhc-admin-move -h
== Synopsis

rhc-admin-move: Move an app from one node to another

== Usage

rhc-admin-move OPTIONS

Options:
--gear_uuid <gear_uuid>
    Gear uuid to move, if app is a scalable application
--app_uuid   <app_uuid>
    Application uuid that the gear belongs to (Optional argument)
--destination_district_uuid <district_uuid>
    Destination district uuid
-i|--target_server_identity <server_identity>
    Target server identity
-p|--node_profile <node_profile>
    Node profile
-t|--timeout
    timeout
--allow_change_district
    Allow the move to be between districts
-h|--help
    Show Usage info


--gear_uuid <gear_uuid>
    Gear uuid to move, if app is a scalable application
Accutally even when moving a non-scalable app, still need specify this option, so "if app is a scalable application" should be removed.


--app_uuid   <app_uuid>
    Application uuid that the gear belongs to (Optional argument)
This option looks like a little redundant. Becasue one gear only belong to one app, not possible to belong to multiple app. It should be removed now.



Version-Release number of selected component (if applicable):
devenv_1802

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rajat Chopra 2012-05-25 14:12:27 EDT
Fixed with rev# 94989beac3f1796b5dc6479da8e0577a70ffad22
Comment 2 Johnny Liu 2012-05-28 02:54:59 EDT
Verified this bug with devenv_1806, and PASS.

# rhc-admin-move -h
== Synopsis

rhc-admin-move: Move an app from one node to another

== Usage

rhc-admin-move OPTIONS

Options:
--gear_uuid <gear_uuid>
    Gear uuid to move
--destination_district_uuid <district_uuid>
    Destination district uuid
-i|--target_server_identity <server_identity>
    Target server identity
-p|--node_profile <node_profile>
    Node profile
-t|--timeout
    timeout
--allow_change_district
    Allow the move to be between districts
-h|--help
    Show Usage info

Note You need to log in before you can comment on or make changes to this bug.