Bug 825268 - Errai jars contain java source files
Errai jars contain java source files
Status: CLOSED NOTABUG
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: Build Process (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Ryan Zhang
Petr Široký
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 09:59 EDT by Petr Široký
Modified: 2012-09-04 12:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-04 12:10:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Široký 2012-05-25 09:59:09 EDT
Description of problem:
Errai jars (errai-bus-1.1.Final.jar and errai-common-1.1.Final.jar) that are bundled with business-central.war and jbpm-gwt-console-server.war contain appart from class files also Java source files. This is not breaking anything, but it is not standard practice to include source files into jars.
Comment 1 Alexandre Porcelli 2012-05-25 17:57:07 EDT
Definitely this this is not a standard practice, but Errai is a GWT related tool and GWT related libraries usually must provide the source code bundled with it's jars. 
Note that GWT needs those source files in order to transform them into JS code.
Comment 2 manstis 2012-05-25 18:04:53 EDT
(In reply to comment #1)
> Definitely this this is not a standard practice, but Errai is a GWT related
> tool and GWT related libraries usually must provide the source code bundled
> with it's jars. 
> Note that GWT needs those source files in order to transform them into JS
> code.

+1
Comment 3 Petr Široký 2012-09-04 12:10:48 EDT
I see. We can't do much about that, so closing as not a bug.

Note You need to log in before you can comment on or make changes to this bug.