Bug 825269 - [Storage] get on specific disk of VM responses with status 404
[Storage] get on specific disk of VM responses with status 404
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Ori Liel
Jakub Libosvar
infra
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 10:00 EDT by Jakub Libosvar
Modified: 2016-02-10 14:14 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:00:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Libosvar 2012-05-25 10:00:03 EDT
Description of problem:
When user wants to access specific disk of specific VM via API, server responds with status 404.

https://<rhevm>/api/vms/9fc1647b-52e5-474f-b207-895fdb20ad69/disks/59be3019-63fb-4801-9a90-b4d29c046d13

HTTP Status 404 - Could not find resource for relative : /vms/9fc1647b-52e5-474f-b207-895fdb20ad69/disks/59be3019-63fb-4801-9a90-b4d29c046d13 of full path: https://<rhevm>/api/vms/9fc1647b-52e5-474f-b207-895fdb20ad69/disks/59be3019-63fb-4801-9a90-b4d29c046d13

type Status report

message Could not find resource for relative : /vms/9fc1647b-52e5-474f-b207-895fdb20ad69/disks/59be3019-63fb-4801-9a90-b4d29c046d13 of full path: https://<rhevm>/api/vms/9fc1647b-52e5-474f-b207-895fdb20ad69/disks/59be3019-63fb-4801-9a90-b4d29c046d13

description The requested resource (Could not find resource for relative : /vms/9fc1647b-52e5-474f-b207-895fdb20ad69/disks/59be3019-63fb-4801-9a90-b4d29c046d13 of full path: https://<rhevm>/api/vms/9fc1647b-52e5-474f-b207-895fdb20ad69/disks/59be3019-63fb-4801-9a90-b4d29c046d13) is not available.


Version-Release number of selected component (if applicable):
rhevm-backend-3.1.0_0001-11.el6ev.noarch
rhevm-restapi-3.1.0_0001-11.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Have a VM with disk
2. Try to GET the disk
  
Actual results:
404

Expected results:
200 with XML response

Additional info:
No messages in server.log nor engine.log
I tried to set debug level for restapi (maybe badly)
   <category name="org.ovirt.engine.api.restapi">
      <priority value="DEBUG"/>
      <appender-ref ref="ENGINE_LOG"/>
   </category>
Comment 1 Michael Pasternak 2012-05-25 14:07:45 EDT
ori, sounds like an issue you have fixed a while ago - please check.
Comment 3 Ori Liel 2012-05-29 03:53:40 EDT
works for me, probably fixed since this was tested
Comment 4 Jakub Libosvar 2012-06-15 06:08:52 EDT
Verified rhevm-restapi-3.1.0_0001-14.el6ev.noarch

Note You need to log in before you can comment on or make changes to this bug.