Bug 825307 - "vim .." does not show files properly
"vim .." does not show files properly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: vim (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Karsten Hopp
Petr Šplíchal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 11:39 EDT by Petr Šplíchal
Modified: 2016-05-31 21:43 EDT (History)
2 users (show)

See Also:
Fixed In Version: vim-7.0.109-7.1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 652610
Environment:
Last Closed: 2013-01-08 02:33:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2012-05-25 11:39:28 EDT
Affects RHEL5's vim-common-7.0.109-7.el5 as well.

+++ This bug was initially created as a clone of Bug #652610 +++

Description of problem:

Opening (directly) a parent directory in vim results in an almost
empty list of files in the directory. Only a few file name chars
are scattered around the screen. See the example below.

Version-Release number of selected component (if applicable):
vim-enhanced-7.2.411-1.4.el6.x86_64

Steps to Reproduce:
cd /tmp
vim ..
  
Actual results:
" ============================================================================
" Netrw Directory Listing                                        (netrw v134)
"   /tmp/..
"   Sorted by      name
"   Sort sequence: [\/]$,\.h$,\.c$,\.cpp$,*,\.o$,\.obj$,\.info$
"   Quick Help: <F1>:help  -:go up dir  D:delete  R:rename  s:sort-by  x:exec
" ============================================================================
ound/
x/





















erc
sck



Expected results:
" ============================================================================
" Netrw Directory Listing                                        (netrw v134)
"   /
"   Sorted by      name
"   Sort sequence: [\/]$,\.h$,\.c$,\.cpp$,*,\.o$,\.obj$,\.info$
"   Quick Help: <F1>:help  -:go up dir  D:delete  R:rename  s:sort-by  x:exec
" ============================================================================
./
bin/
boot/
cgroup/
dev/
etc/
home/
lib/
lib64/
lost+found/
media/
mnt/
opt/
proc/
root/
sbin/
selinux/
srv/
sys/
tmp/
usr/
var/
.autofsck
profilerc
Comment 1 RHEL Product and Program Management 2012-05-25 11:57:15 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 errata-xmlrpc 2013-01-08 02:33:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0066.html

Note You need to log in before you can comment on or make changes to this bug.