Bug 825312 - mongodb interaction seems to hate package names that contain a '.' such as openoffice.org rpms.
mongodb interaction seems to hate package names that contain a '.' such as op...
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.4.0
Assigned To: pulp-bugs
Preethi Thomas
: Triaged
Depends On: 818640
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 11:57 EDT by Preethi Thomas
Modified: 2014-08-09 02:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 818640
Environment:
Last Closed: 2014-08-09 02:57:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-05-25 11:57:42 EDT
Cloning the original bug for 2.0

+++ This bug was initially created as a clone of Bug #818640 +++

Description of problem:
When syncing the rhel6-optional repository, the sync fails with:
InvalidDocument: key 'openoffice.org-langpack-en' must not contain '.'

Version-Release number of selected component (if applicable):
pulp-1.1.7-1.el6.noarch
mongodb-1.8.2-2.el6.x86_64


How reproducible:
Always

Steps to Reproduce:
1.pulp-admin repo create --id live-rhel6-opt --feed=https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/optional/os --feed_ca=mine --feed_key=mine --feed_cert=mine --relativepath=/live/rhel6/optional
2.pulp-admin repo sync --id live-rhel6-opt
3.pulp-admin repo status --id live-rhel6-opt
  
Actual results:
fails with InvalidDocument: key 'openoffice.org-langpack-en' must not contain '.'

Expected results:
repository syncs successfully. 

Additional info:
2012-05-03 10:20:31,167 22480:140181933876992: pulp.server.tasking.task:ERROR: task:472 Task failed: Task 8be02882-952f-11e1-ba57-bc305ba1aebf: _sync(live-rhel6-opt, synchronizer=<pulp.server.api.synchronizers.YumSynchronizer object at 0x7f7eb403ea50>, skip={}, max_speed=None, threads=None, progress_callback=<bound method RepoSyncTask.progress_callback of <pulp.server.api.repo_sync_task.RepoSyncTask object at 0x7f7eb403e510>>)
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp/server/tasking/task.py", line 418, in run
    result = self.callable(*self.args, **self.kwargs)
  File "/usr/lib/python2.6/site-packages/pulp/server/api/repo_sync.py", line 283, in _sync
    progress_callback, synchronizer, max_speed, threads)
  File "/usr/lib/python2.6/site-packages/pulp/server/api/repo_sync.py", line 379, in fetch_content
    added_errataids = synchronizer.import_metadata(repo_dir, repo_id, skip_dict)
  File "/usr/lib/python2.6/site-packages/pulp/server/api/synchronizers.py", line 415, in import_metadata
    self.repo_api.collection.save(repo, safe=True)
  File "/usr/lib/python2.6/site-packages/pulp/server/db/connection.py", line 80, in retry
    return method(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/pymongo/collection.py", line 237, in save
    manipulate, safe, _check_keys=True, **kwargs)
  File "/usr/lib/python2.6/site-packages/pulp/server/db/connection.py", line 80, in retry
    return method(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/pymongo/collection.py", line 411, in update
    _check_keys, self.__uuid_subtype), safe)
InvalidDocument: key 'openoffice.org-langpack-en' must not contain '.'
Comment 1 Steven Roberts 2012-12-20 00:04:45 EST
FYI, looks to be handed in 2.0 pulp w/ mongo 2.0.  I sync the optional feed from RHN and it is working fine.  I checked mongo and see this:

> find( { name: 'openoffice.org-langpack-en' }, { name: 1, version: 1, release: 1, epoch: 1, arch: 1}
{ "arch" : "x86_64", "_id" : "150a6c00-994f-441e-9257-495f5e051727", "epoch" : "1", "version" : "3.2.
1", "name" : "openoffice.org-langpack-en", "release" : "19.6.el6" }                                  
{ "arch" : "x86_64", "_id" : "f21db7f7-fef3-4493-9410-82a26a098ad8", "epoch" : "1", "version" : "3.2.
1", "name" : "openoffice.org-langpack-en", "release" : "19.6.el6_0.5" }                              
{ "arch" : "x86_64", "_id" : "1e612a9b-7777-4096-9466-66643688243b", "epoch" : "1", "version" : "3.2.
1", "name" : "openoffice.org-langpack-en", "release" : "19.6.el6_2.7" }                              
> 

so looks like it can handle them now.
Comment 2 Randy Barlow 2014-01-02 16:37:58 EST
I believe this issue is resolved.
Comment 3 Randy Barlow 2014-03-17 18:00:10 EDT
I'm going to mark this for the 2.4.0 release so that it can go through QE.
Comment 4 Preethi Thomas 2014-04-11 05:07:00 EDT
verified
[root@hp-dl380pgen8-02-vm-1 ~]# rpm -qa pulp-server
pulp-server-2.4.0-0.8.beta.el6.noarch
[root@hp-dl380pgen8-02-vm-1 ~]# 

[root@hp-dl380pgen8-02-vm-1 ~]# pulp-admin rpm repo create --repo-id live-rhel6-opt --feed=https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/optional/os --feed-ca-cert CDN/cdn.redhat.com-chain.crt --feed-cert CDN/1391032266_4771.crt  --feed-key CDN/1391032266_4771.key 
Successfully created repository [live-rhel6-opt]

[root@hp-dl380pgen8-02-vm-1 ~]# pulp-admin rpm repo sync run --repo-id live-rhel6-opt
+----------------------------------------------------------------------+
               Synchronizing Repository [live-rhel6-opt]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.


Downloading metadata...
[-]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       7058/7058 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed


Task Succeeded



Publishing rpms...
[==================================================] 100%
Rpms: 7058/7058 items
... completed
[==================================================] 100%
Errata: 1228/1228 items
... completed
[==================================================] 100%
Comps: 3/3 items
... completed

Publishing repository over HTTPS
[-]
... completed


Task Succeeded
Comment 5 Randy Barlow 2014-08-09 02:57:09 EDT
This has been fixed in Pulp 2.4.0-1.

Note You need to log in before you can comment on or make changes to this bug.