Bug 825337 - TypeError: coercing to Unicode: need string or buffer, NoneType found
TypeError: coercing to Unicode: need string or buffer, NoneType found
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:93427c233561f8727d78264b411...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 14:07 EDT by Brian Lane
Modified: 2012-10-23 12:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 12:02:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-gVaL7v (305.74 KB, text/plain)
2012-05-25 14:07 EDT, Brian Lane
no flags Details

  None (edit)
Description Brian Lane 2012-05-25 14:07:01 EDT
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-gVaL7v
hashmarkername: anaconda
kernel:         3.3.4-5.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Fri 25 May 2012 06:05:31 PM UTC
version:        17

anaconda-tb-gVaL7v: Text file, 313079 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.29 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 913, in status
:    return os.access(self.path, os.W_OK)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 3423, in setup
:    log_method_call(self, self.name, orig=orig, status=self.status,
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2012, in _parseOneLine
:    device.setup()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2112, in parseFSTab
:    device = self._parseOneLine((devspec, mountpoint, fstype, options, dump, passno))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1676, in mountExistingSystem
:    fsset.parseFSTab(anaconda=anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/upgrade.py", line 178, in upgradeMountFilesystems
:    mountExistingSystem(anaconda, anaconda.upgradeRoot[0], allowDirty = 0)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 88, in return_false
:    func(*args, **kwargs)
:TypeError: coercing to Unicode: need string or buffer, NoneType found

environ:
:LANG=en_US.UTF-8
:repo=hd::/var/cache/yum/preupgrade
:TERM=linux
:BOOT_IMAGE=/upgrade/vmlinuz
:XAUTHORITY=/root/.Xauthority
:LC_NUMERIC=C
:SHLVL=0
:PYTHONPATH=/tmp/updates
:LVM_SUPPRESS_FD_WARNINGS=1
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:GNOME_DISABLE_CRASH_DIALOG=1
:ks=hd:UUID=5e107c83-0c1d-46d5-a181-d5209c3c5589:/upgrade/ks.cfg
:PWD=/
:MALLOC_PERTURB_=204
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:stage2=hd:UUID=5e107c83-0c1d-46d5-a181-d5209c3c5589:/upgrade/squashfs.img
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 Brian Lane 2012-05-25 14:07:05 EDT
Created attachment 586915 [details]
File: anaconda-tb-gVaL7v
Comment 2 Brian Lane 2012-05-25 14:08:47 EDT
Tried to do a preupgrade from F17 in a Parallels virt.
Comment 3 Brian Lane 2012-05-25 14:09:37 EDT
Arrg. From F16. Fully updated before running preupgrade-cli.
Comment 4 Brian Lane 2012-06-02 13:56:26 EDT
This is caused by parallels having an entry in fstab that starts with:

none /media/pfs prl_fs

A workaround would be to comment out or remove the line from fstab before upgrading.
Comment 5 Jon Burgess 2012-07-03 17:28:05 EDT
I saw an identical traceback when doing a f16->f17 upgrade. In my case it was due to having a debugfs entry defined in /etc/fstab:

none    /sys/kernel/debug    debugfs defaults  0 0

I can give you the logs on a new BZ if they will help at all.
Comment 6 Brian Lane 2012-10-23 12:02:26 EDT
Anaconda no longer handles upgrades.

Note You need to log in before you can comment on or make changes to this bug.