Bug 825424 - (sagator) SELinux is preventing /usr/bin/updatedb from 'read' accesses on the directory /usr/share/sagator.
SELinux is preventing /usr/bin/updatedb from 'read' accesses on the directory...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:15276ebfd7e6fe1195f22848956...
:
: 825432 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 01:51 EDT by geminic86
Modified: 2012-05-29 13:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 13:36:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description geminic86 2012-05-26 01:51:18 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc16.i686.PAE
time:           Sat 26 May 2012 01:50:57 AM EDT

description:
:SELinux is preventing /usr/bin/updatedb from 'read' accesses on the directory /usr/share/sagator.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that updatedb should be allowed read access on the sagator directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep updatedb /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:locate_t:SystemLow-SystemHigh
:Target Context                system_u:object_r:sagator_t:SystemLow
:Target Objects                /usr/share/sagator [ dir ]
:Source                        updatedb
:Source Path                   /usr/bin/updatedb
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           mlocate-0.24-1.fc16.i686
:Target RPM Packages           sagator-core-1.2.3-1.fc16.noarch
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.6-3.fc16.i686.PAE #1 SMP Wed May
:                              16 22:18:40 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Fri 25 May 2012 02:20:00 PM EDT
:Last Seen                     Fri 25 May 2012 02:20:00 PM EDT
:Local ID                      c1cc6f1c-03fb-44f4-a163-90b4589ef0c4
:
:Raw Audit Messages
:type=AVC msg=audit(1337970000.994:330): avc:  denied  { read } for  pid=5412 comm="updatedb" name="sagator" dev="dm-1" ino=205695 scontext=system_u:system_r:locate_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sagator_t:s0 tclass=dir
:
:
:type=AVC msg=audit(1337970000.994:330): avc:  denied  { open } for  pid=5412 comm="updatedb" name="sagator" dev="dm-1" ino=205695 scontext=system_u:system_r:locate_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sagator_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1337970000.994:330): arch=i386 syscall=open success=yes exit=ECHILD a0=804fb8a a1=8000 a2=0 a3=bfb75310 items=0 ppid=5406 pid=5412 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=17 comm=updatedb exe=/usr/bin/updatedb subj=system_u:system_r:locate_t:s0-s0:c0.c1023 key=(null)
:
:Hash: updatedb,locate_t,sagator_t,dir,read
:
:audit2allow
:
:#============= locate_t ==============
:allow locate_t sagator_t:dir { read open };
:
:audit2allow -R
:
:#============= locate_t ==============
:allow locate_t sagator_t:dir { read open };
:
Comment 1 Daniel Walsh 2012-05-29 13:36:29 EDT
sagator_t is not a type that we ship.  Where ever you got the policy from is screwed up.

Either sagator_t is not a file type and should not be put on disk or sagator_t needs to have files_type(sagator_t) added.
Comment 2 Daniel Walsh 2012-05-29 13:37:03 EDT
*** Bug 825432 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.