Bug 825432 - SELinux is preventing /usr/bin/updatedb from 'search' accesses on the directory /usr/share/sagator.
SELinux is preventing /usr/bin/updatedb from 'search' accesses on the directo...
Status: CLOSED DUPLICATE of bug 825424
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:625f6f7d96afa526ccfa38f7b2c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 05:21 EDT by geminic86
Modified: 2012-05-29 13:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 13:37:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description geminic86 2012-05-26 05:21:33 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc16.i686.PAE
time:           Sat 26 May 2012 05:21:20 AM EDT

description:
:SELinux is preventing /usr/bin/updatedb from 'search' accesses on the directory /usr/share/sagator.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that updatedb should be allowed search access on the sagator directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep updatedb /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:locate_t:SystemLow-SystemHigh
:Target Context                system_u:object_r:sagator_t:SystemLow
:Target Objects                /usr/share/sagator [ dir ]
:Source                        updatedb
:Source Path                   /usr/bin/updatedb
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           mlocate-0.24-1.fc16.i686
:Target RPM Packages           sagator-core-1.2.3-1.fc16.noarch
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc16.i686.PAE #1 SMP Tue May
:                              22 14:07:22 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Sat 26 May 2012 03:12:27 AM EDT
:Last Seen                     Sat 26 May 2012 03:12:27 AM EDT
:Local ID                      0f9d3025-fc39-4e6e-87cf-8c962b372aba
:
:Raw Audit Messages
:type=AVC msg=audit(1338016347.632:1434): avc:  denied  { search } for  pid=22524 comm="updatedb" name="sagator" dev="dm-1" ino=205695 scontext=system_u:system_r:locate_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sagator_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1338016347.632:1434): arch=i386 syscall=chdir success=yes exit=0 a0=9eec65d a1=bf8231c0 a2=ffffffff a3=bf8231c0 items=0 ppid=22518 pid=22524 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=139 comm=updatedb exe=/usr/bin/updatedb subj=system_u:system_r:locate_t:s0-s0:c0.c1023 key=(null)
:
:Hash: updatedb,locate_t,sagator_t,dir,search
:
:audit2allow
:
:#============= locate_t ==============
:allow locate_t sagator_t:dir search;
:
:audit2allow -R
:
:#============= locate_t ==============
:allow locate_t sagator_t:dir search;
:
Comment 1 Daniel Walsh 2012-05-29 13:37:03 EDT

*** This bug has been marked as a duplicate of bug 825424 ***

Note You need to log in before you can comment on or make changes to this bug.