Bug 825434 - SELinux is preventing /usr/bin/python2.7 from using the 'chown' capabilities.
SELinux is preventing /usr/bin/python2.7 from using the 'chown' capabilities.
Status: CLOSED DUPLICATE of bug 825433
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6dd29121c683f688de1687286b1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 05:22 EDT by geminic86
Modified: 2012-05-28 02:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-28 02:57:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description geminic86 2012-05-26 05:22:47 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc16.i686.PAE
time:           Sat 26 May 2012 05:22:33 AM EDT

description:
:SELinux is preventing /usr/bin/python2.7 from using the 'chown' capabilities.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should have the chown capability by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep sagator /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:sagator_t:SystemLow
:Target Context                system_u:system_r:sagator_t:SystemLow
:Target Objects                 [ capability ]
:Source                        sagator
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-1.fc16.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc16.i686.PAE #1 SMP Tue May
:                              22 14:07:22 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Sat 26 May 2012 03:11:20 AM EDT
:Last Seen                     Sat 26 May 2012 03:11:20 AM EDT
:Local ID                      c08a375f-e5a6-4e31-a365-d1a27e58f699
:
:Raw Audit Messages
:type=AVC msg=audit(1338016280.373:1428): avc:  denied  { chown } for  pid=11579 comm="sagator" capability=0  scontext=system_u:system_r:sagator_t:s0 tcontext=system_u:system_r:sagator_t:s0 tclass=capability
:
:
:type=SYSCALL msg=audit(1338016280.373:1428): arch=i386 syscall=chown32 success=yes exit=0 a0=a179250 a1=3ba a2=3ab a3=9f72050 items=0 ppid=1 pid=11579 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=sagator exe=/usr/bin/python2.7 subj=system_u:system_r:sagator_t:s0 key=(null)
:
:Hash: sagator,sagator_t,sagator_t,capability,chown
:
:audit2allow
:
:#============= sagator_t ==============
:allow sagator_t self:capability chown;
:
:audit2allow -R
:
:#============= sagator_t ==============
:allow sagator_t self:capability chown;
:
Comment 1 Miroslav Grepl 2012-05-28 02:57:19 EDT

*** This bug has been marked as a duplicate of bug 825433 ***

Note You need to log in before you can comment on or make changes to this bug.