Bug 825435 - SELinux is preventing /usr/sbin/logrotate from 'setattr' accesses on the file /var/spool/vscan/var/log/sagator/sagator.log.
SELinux is preventing /usr/sbin/logrotate from 'setattr' accesses on the file...
Status: CLOSED DUPLICATE of bug 825433
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:2c5bcfe46b376aa2a8f1afe4527...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 05:23 EDT by geminic86
Modified: 2012-05-28 02:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-28 02:57:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description geminic86 2012-05-26 05:23:09 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc16.i686.PAE
time:           Sat 26 May 2012 05:22:55 AM EDT

description:
:SELinux is preventing /usr/sbin/logrotate from 'setattr' accesses on the file /var/spool/vscan/var/log/sagator/sagator.log.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that logrotate should be allowed setattr access on the sagator.log file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep logrotate /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:logrotate_t:SystemLow-SystemHigh
:Target Context                system_u:object_r:sagator_var_t:SystemLow
:Target Objects                /var/spool/vscan/var/log/sagator/sagator.log [
:                              file ]
:Source                        logrotate
:Source Path                   /usr/sbin/logrotate
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           logrotate-3.8.0-3.fc16.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc16.i686.PAE #1 SMP Tue May
:                              22 14:07:22 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Sat 26 May 2012 03:11:20 AM EDT
:Last Seen                     Sat 26 May 2012 03:11:20 AM EDT
:Local ID                      2a1c70b1-a32b-4da7-90e9-3a3bd98104fd
:
:Raw Audit Messages
:type=AVC msg=audit(1338016280.363:1426): avc:  denied  { setattr } for  pid=17285 comm="logrotate" name="sagator.log" dev="dm-1" ino=1710822 scontext=system_u:system_r:logrotate_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sagator_var_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1338016280.363:1426): arch=i386 syscall=fchmod success=yes exit=0 a0=3 a1=180 a2=3 a3=bfefcf68 items=0 ppid=17283 pid=17285 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=139 comm=logrotate exe=/usr/sbin/logrotate subj=system_u:system_r:logrotate_t:s0-s0:c0.c1023 key=(null)
:
:Hash: logrotate,logrotate_t,sagator_var_t,file,setattr
:
:audit2allow
:
:#============= logrotate_t ==============
:allow logrotate_t sagator_var_t:file setattr;
:
:audit2allow -R
:
:#============= logrotate_t ==============
:allow logrotate_t sagator_var_t:file setattr;
:
Comment 1 Miroslav Grepl 2012-05-28 02:57:13 EDT

*** This bug has been marked as a duplicate of bug 825433 ***

Note You need to log in before you can comment on or make changes to this bug.