Bug 825436 - SELinux is preventing /usr/bin/python2.7 from 'open' accesses on the chr_file /var/spool/vscan/dev/urandom.
SELinux is preventing /usr/bin/python2.7 from 'open' accesses on the chr_file...
Status: CLOSED DUPLICATE of bug 825433
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:eed8ac3afc97514e372dd67fb33...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 05:24 EDT by geminic86
Modified: 2012-05-28 02:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-28 02:57:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description geminic86 2012-05-26 05:24:07 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc16.i686.PAE
time:           Sat 26 May 2012 05:23:55 AM EDT

description:
:SELinux is preventing /usr/bin/python2.7 from 'open' accesses on the chr_file /var/spool/vscan/dev/urandom.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed open access on the urandom chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep sagator /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:sagator_t:SystemLow
:Target Context                system_u:object_r:sagator_device_t:SystemLow
:Target Objects                /var/spool/vscan/dev/urandom [ chr_file ]
:Source                        sagator
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-1.fc16.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc16.i686.PAE #1 SMP Tue May
:                              22 14:07:22 UTC 2012 i686 i686
:Alert Count                   2
:First Seen                    Sat 26 May 2012 01:54:56 AM EDT
:Last Seen                     Sat 26 May 2012 01:54:57 AM EDT
:Local ID                      69f2574d-32ac-4a0b-9e99-be9193266081
:
:Raw Audit Messages
:type=AVC msg=audit(1338011697.227:1061): avc:  denied  { open } for  pid=11909 comm="sagator" name="urandom" dev="dm-1" ino=1338858 scontext=system_u:system_r:sagator_t:s0 tcontext=system_u:object_r:sagator_device_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1338011697.227:1061): arch=i386 syscall=open success=yes exit=ENXIO a0=500a842d a1=8000 a2=0 a3=10 items=0 ppid=11579 pid=11909 auid=4294967295 uid=954 gid=939 euid=954 suid=954 fsuid=954 egid=939 sgid=939 fsgid=939 tty=(none) ses=4294967295 comm=sagator exe=/usr/bin/python2.7 subj=system_u:system_r:sagator_t:s0 key=(null)
:
:Hash: sagator,sagator_t,sagator_device_t,chr_file,open
:
:audit2allow
:
:#============= sagator_t ==============
:allow sagator_t sagator_device_t:chr_file open;
:
:audit2allow -R
:
:#============= sagator_t ==============
:allow sagator_t sagator_device_t:chr_file open;
:
Comment 1 Miroslav Grepl 2012-05-28 02:57:39 EDT

*** This bug has been marked as a duplicate of bug 825433 ***

Note You need to log in before you can comment on or make changes to this bug.