Bug 825440 - SELinux is preventing /bin/chmod from 'setattr' accesses on the chr_file /var/spool/vscan/dev/null.
SELinux is preventing /bin/chmod from 'setattr' accesses on the chr_file /var...
Status: CLOSED DUPLICATE of bug 825433
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6c3b0a8436edc16cb9ff00f7a9b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-26 05:25 EDT by geminic86
Modified: 2012-05-28 02:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-28 02:59:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description geminic86 2012-05-26 05:25:05 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc16.i686.PAE
time:           Sat 26 May 2012 05:24:54 AM EDT

description:
:SELinux is preventing /bin/chmod from 'setattr' accesses on the chr_file /var/spool/vscan/dev/null.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that chmod should be allowed setattr access on the null chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep chmod /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:initrc_t:SystemLow
:Target Context                system_u:object_r:sagator_device_t:SystemLow
:Target Objects                /var/spool/vscan/dev/null [ chr_file ]
:Source                        chmod
:Source Path                   /bin/chmod
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           coreutils-8.12-7.fc16.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-86.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc16.i686.PAE #1 SMP Tue May
:                              22 14:07:22 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    Sat 26 May 2012 01:54:48 AM EDT
:Last Seen                     Sat 26 May 2012 01:54:48 AM EDT
:Local ID                      05c20cf5-32dd-40f1-95b9-c90a06e7002a
:
:Raw Audit Messages
:type=AVC msg=audit(1338011688.101:1013): avc:  denied  { setattr } for  pid=11360 comm="chmod" name="null" dev="dm-1" ino=1338856 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:sagator_device_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1338011688.101:1013): arch=i386 syscall=fchmodat success=yes exit=0 a0=ffffff9c a1=89598e8 a2=1b6 a3=895aa98 items=0 ppid=11064 pid=11360 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=chmod exe=/bin/chmod subj=system_u:system_r:initrc_t:s0 key=(null)
:
:Hash: chmod,initrc_t,sagator_device_t,chr_file,setattr
:
:audit2allow
:
:#============= initrc_t ==============
:allow initrc_t sagator_device_t:chr_file setattr;
:
:audit2allow -R
:
:#============= initrc_t ==============
:allow initrc_t sagator_device_t:chr_file setattr;
:
Comment 1 Miroslav Grepl 2012-05-28 02:59:11 EDT

*** This bug has been marked as a duplicate of bug 825433 ***

Note You need to log in before you can comment on or make changes to this bug.