Bug 825528 - SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'rmdir' accesses on the directory 4MV934Z2.
SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'rmdir' ac...
Status: CLOSED DUPLICATE of bug 825527
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6ffff8115b74ff29859e95d9f97...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-27 08:46 EDT by Michal Nowak
Modified: 2013-03-07 21:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-28 04:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2012-05-27 08:46:40 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Sun 27 May 2012 02:46:27 PM CEST

description:
:SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from 'rmdir' accesses on the directory 4MV934Z2.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that plugin-container should be allowed rmdir access on the 4MV934Z2 directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                4MV934Z2 [ dir ]
:Source                        plugin-containe
:Source Path                   /usr/lib64/xulrunner-2/plugin-container
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           xulrunner-12.0-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-125.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP Mon May 21
:                              22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Sun 27 May 2012 02:46:06 PM CEST
:Last Seen                     Sun 27 May 2012 02:46:06 PM CEST
:Local ID                      462c7aa8-61f0-4cba-9822-fdce392a2bf5
:
:Raw Audit Messages
:type=AVC msg=audit(1338122766.847:510): avc:  denied  { rmdir } for  pid=27945 comm="plugin-containe" name="4MV934Z2" dev="dm-0" ino=8653712 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1338122766.847:510): arch=x86_64 syscall=rmdir success=no exit=EACCES a0=7f57dafc0ac0 a1=0 a2=7f57e74b0048 a3=3e43f77de5 items=0 ppid=27901 pid=27945 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm=plugin-containe exe=/usr/lib64/xulrunner-2/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: plugin-containe,mozilla_plugin_t,user_home_t,dir,rmdir
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-05-28 04:05:19 EDT

*** This bug has been marked as a duplicate of bug 825527 ***

Note You need to log in before you can comment on or make changes to this bug.