Bug 825649 - [RFE] support qed format with backing file in virt-manager
[RFE] support qed format with backing file in virt-manager
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 02:45 EDT by Huang Wenlong
Modified: 2014-07-06 15:31 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-01 18:47:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Huang Wenlong 2012-05-28 02:45:42 EDT
Description of problem:
RFE support qed with backing file in virt-manager
virt-manger support qcow2 image with backing file  but do not support qed with backing file


Version-Release number of selected component (if applicable):
virt-manager-0.9.0-14.el6.x86_64
libvirt-0.9.10-21.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.294.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1. create a qed with backing file in the default pool 
# qemu-img create -f qed -b /var/lib/libvirt/images/qed-bf.img /var/lib/libvirt/images/qed-bf2.img 1G
Formatting '/var/lib/libvirt/images/qed-bf2.img', fmt=qed size=1073741824 backing_file='/var/lib/libvirt/images/qed-bf.img' cluster_size=0 table_size=0

2. in the virt-manager  try to open the default pool
Error refreshing hardware page: internal error unknown volume format number -2

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/details.py", line 1201, in hw_selected
    self.refresh_disk_page()
  File "/usr/share/virt-manager/virtManager/details.py", line 2684, in refresh_disk_page
    size = vol.get_pretty_capacity()
  File "/usr/share/virt-manager/virtManager/storagevol.py", line 60, in get_pretty_capacity
    return util.pretty_bytes(self.get_capacity())
  File "/usr/share/virt-manager/virtManager/storagevol.py", line 57, in get_capacity
    return long(util.xpath(self.get_xml(), "/volume/capacity"))
  File "/usr/share/virt-manager/virtManager/libvirtobject.py", line 93, in get_xml
    self.refresh_xml()
  File "/usr/share/virt-manager/virtManager/libvirtobject.py", line 105, in refresh_xml
    self._xml = self._XMLDesc(self._active_xml_flags)
  File "/usr/share/virt-manager/virtManager/storagevol.py", line 35, in _XMLDesc
    return self.vol.XMLDesc(flags)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 2267, in XMLDesc
    if ret is None: raise libvirtError ('virStorageVolGetXMLDesc() failed', vol=self)
libvirtError: internal error unknown volume format number -2


Actual results:
report error

Expected results:
support qed with backing file

Additional info:
if qed image without backing file  it  works well .
Comment 1 RHEL Product and Program Management 2012-07-10 02:55:23 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 21:57:39 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Cole Robinson 2014-02-01 18:47:39 EST
This is a libvirt bug, long since fixed.

Note You need to log in before you can comment on or make changes to this bug.