Bug 825683 - software error appear when I am trying to publish one cert
software error appear when I am trying to publish one cert
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wei Shen
:
Depends On:
Blocks: 733411
  Show dependency treegraph
 
Reported: 2012-05-28 04:24 EDT by QinXie
Modified: 2014-06-22 21:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 02:11:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Wei Shen 2012-05-30 06:13:53 EDT
Created attachment 587661 [details]
work around for the bug
Comment 2 Wei Shen 2012-05-30 06:17:08 EDT
I haven't found the root cause, so provide a work around for it.
Comment 3 Tony Fu 2012-05-30 22:14:24 EDT
Comment on attachment 587661 [details]
work around for the bug

The patch looks good.

One thing I would suggest is that we update the "flag_nonexistent" error message as well to ask user to reload the cert and try again.  At the moment, the "flag_nonexistent" error msg just says xxxx is not a valid flag number, and the user probably doesn't know what to do next.
Comment 5 Wei Shen 2012-05-30 23:25:42 EDT
Created attachment 587928 [details]
the patch with tfu's suggestion
Comment 6 Wei Shen 2012-05-30 23:44:58 EDT
Created attachment 587929 [details]
new patch
Comment 7 Tony Fu 2012-05-31 00:48:45 EDT
Comment on attachment 587929 [details]
new patch

I have applied it on web2 and it works there.
Comment 8 Wei Shen 2013-02-01 02:11:09 EST
This issue has been already fixed in hwcert.noarch 0:3.2rh-20120531.1 , so close it

Note You need to log in before you can comment on or make changes to this bug.