Bug 825772 - [abrt] kernel: kernel BUG at mm/rmap.c:1132!
[abrt] kernel: kernel BUG at mm/rmap.c:1132!
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:b63d7a17f5097bc13f52420ca8d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 08:32 EDT by thj
Modified: 2012-07-13 06:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 06:57:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description thj 2012-05-28 08:32:23 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.6-3.fc16.x86_64 root=UUID=b864080a-2138-4f36-a06d-98f0b838f592 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
event_log:      2012-05-28-12:31:05> Smolt profile successfully saved
kernel:         3.3.6-3.fc16.x86_64
reason:         kernel BUG at mm/rmap.c:1132!
time:           Wed 23 May 2012 05:58:13 PM GMT

backtrace:
:kernel BUG at mm/rmap.c:1132!
:invalid opcode: 0000 [#1] SMP 
:CPU 0 
:Modules linked in: ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge stp llc be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi serio_raw microcode k10temp edac_core edac_mce_amd fam15h_power sp5100_tco r8169 mii snd_hda_codec_realtek i2c_piix4 snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc vhost_net macvtap macvlan tun virtio_net kvm_amd kvm uinput firewire_ohci firewire_core crc_itu_t nouveau ttm drm_kms_helper drm i2c_core mxm_wmi video wmi [last unloaded: scsi_wait_scan]
:Pid: 2097, comm: kwin Not tainted 3.3.6-3.fc16.x86_64 #1 Gigabyte Technology Co., Ltd. GA-990FXA-UD5/GA-990FXA-UD5
:RIP: 0010:[<ffffffff81150ba3>]  [<ffffffff81150ba3>] page_add_new_anon_rmap+0xc3/0xd0
:RSP: 0000:ffff8803dcc1fcf8  EFLAGS: 00010202
:RAX: ffff88040e6dae60 RBX: ffffea000e31cec0 RCX: 800000038c73b067
:RDX: 00007f1324654010 RSI: ffff8803b4d859a0 RDI: ffffea000e31cec0
:RBP: ffff8803dcc1fd18 R08: 0000000000034362 R09: 0000000000000000
:R10: 0000000000000000 R11: 000000385397b500 R12: ffff8803b4d859a0
:R13: 00007f1324654010 R14: 00007f1324654010 R15: ffff8803fe66d2a0
:FS:  00007f133092d840(0000) GS:ffff88042ec00000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
:CR2: 00007f1324654010 CR3: 0000000415a4b000 CR4: 00000000000406f0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process kwin (pid: 2097, threadinfo ffff8803dcc1e000, task ffff88040e6dae60)
:Stack:
: 00007f1324654010 ffff8803b4d859a0 ffffea000ff99b70 ffffea000e31cec0
: ffff8803dcc1fde8 ffffffff8114691d ffff8803d4b95d08 ffff8803fd2b2e70
: ffff8803b4d859a0 ffff8803b4d859a0 00007f1324664000 00007f1324641000
:Call Trace:
: [<ffffffff8114691d>] handle_pte_fault+0x82d/0xad0
: [<ffffffff8114bda1>] ? vma_merge+0x121/0x340
: [<ffffffff81176805>] ? mem_cgroup_count_vm_event+0x15/0x60
: [<ffffffff81146f78>] handle_mm_fault+0x1f8/0x350
: [<ffffffff815f7ea2>] do_page_fault+0x142/0x4f0
: [<ffffffff8114d188>] ? do_mmap_pgoff+0x348/0x360
: [<ffffffff815f4a75>] page_fault+0x25/0x30
:Code: be 07 00 00 00 e8 ae d8 fe ff eb b8 0f 1f 40 00 48 89 df be 01 00 00 00 e8 7b d2 fd ff 48 8b 5d e8 4c 8b 65 f0 4c 8b 6d f8 c9 c3 <0f> 0b e8 39 b8 49 00 66 0f 1f 44 00 00 55 48 89 e5 53 48 83 ec 
:RIP  [<ffffffff81150ba3>] page_add_new_anon_rmap+0xc3/0xd0
: RSP <ffff8803dcc1fcf8>

smolt_data:
:
:
:General
:=================================
:UUID: 654c197a-4c87-47a0-ab18-b8a85a0a5e0c
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6199.85
:CPU Vendor: AuthenticAMD
:CPU Model: AMD FX(tm)-8120 Eight-Core Processor
:CPU Stepping: 2
:CPU Family: 21
:CPU Model Num: 1
:Number of CPUs: 8
:CPU Speed: 3100
:System Memory: 16032
:System Swap: 10239
:Vendor: Gigabyte Technology Co., Ltd.
:System: GA-990FXA-UD5 
:Form factor: Desktop
:Kernel: 3.3.5-2.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4098:17297:5208:45058) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
:(4098:23069:5208:20480) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (external gfx1 port A)
:(4318:3592:5208:13615) pci, snd_hda_intel, MULTIMEDIA, HDMI Audio stub
:(4098:23060:5208:20480) pci, None, HOST/PCI, RD890 PCI to PCI bridge (external gfx0 port B)
:(4130:5637:0:0) pci, None, HOST/PCI, Family 15h Processor Function 5
:(4130:5636:0:0) pci, fam15h_power, HOST/PCI, Family 15h Processor Function 4
:(4130:5633:0:0) pci, None, HOST/PCI, Family 15h Processor Function 1
:(4130:5632:0:0) pci, None, HOST/PCI, Family 15h Processor Function 0
:(4130:5635:0:0) pci, k10temp, HOST/PCI, Family 15h Processor Function 3
:(4130:5634:0:0) pci, None, HOST/PCI, Family 15h Processor Function 2
:(4098:17302:5208:20484) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:5208:20484) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(6987:37234:5208:45056) pci, ahci, STORAGE, N/A
:(6987:37234:5208:45056) pci, ahci, STORAGE, N/A
:(4098:17312:4098:0) pci, pcieport, PCI/PCI, SB700/SB800 PCI to PCI bridge (PCIE port 0)
:(4098:17313:4098:0) pci, pcieport, PCI/PCI, SB700/SB800 PCI to PCI bridge (PCIE port 1)
:(4098:17314:4098:0) pci, pcieport, PCI/PCI, N/A
:(4098:17315:4098:0) pci, pcieport, PCI/PCI, N/A
:(4098:23062:5208:20480) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (PCI express gpp port B)
:(4098:17285:0:0) pci, None, SERIAL, SBx00 SMBus Controller
:(4098:17309:4098:17309) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:5208:41266) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17305:5208:20484) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(7023:28707:5208:20487) pci, xhci_hcd, USB, N/A
:(4358:12356:5208:4096) pci, firewire_ohci, FIREWIRE, GA-7VT600-1394 Motherboard
:(4098:17302:5208:20484) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4318:4160:5208:13615) pci, nouveau, VIDEO, N/A
:(4098:17303:5208:20484) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:17302:5208:20484) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:5208:20484) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(7023:28707:5208:20487) pci, xhci_hcd, USB, N/A
:(4098:23068:5208:20480) pci, pcieport, PCI/PCI, RD890 PCI to PCI bridge (PCI express gpp port H)
:(4332:33128:5208:57344) pci, r8169, ETHERNET, GA-EP45-DS5 Motherboard
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda2 / ext4 4096 4096 12721371 10403873 9766536 3186688 2865258 2865258
:/dev/sda1 /boot ext4 4096 4096 261467 230623 217516 65536 65305 65305
:/dev/sdb2 /home ext4 4096 4096 130933269 119909006 113355406 32768000 32746371 32746371
:/dev/sdb1 WITHHELD ext4 4096 4096 160532220 99398430 91363512 40181760 40181695 40181695
:/dev/sdb4 /opt ext4 4096 4096 65460469 64459851 61183051 16384000 16383989 16383989
:/dev/sdb3 /var ext4 4096 4096 130933269 127745364 121191764 32768000 32731348 32731348
:
Comment 1 Dave Jones 2012-05-29 10:09:55 EDT
This smells like memory corruption.  Possibly related to the same root cause as your other bug 825763
Comment 2 thj 2012-06-07 16:16:00 EDT
Took the computer to the dealer and they changed my memory. 
Still same or similar error.
Comment 3 Dave Jones 2012-07-10 22:09:30 EDT
do you still see this with 3.4 ?
Comment 4 thj 2012-07-13 06:57:01 EDT
No, so I think we can close this. :)

Note You need to log in before you can comment on or make changes to this bug.