Bug 825831 - Only some plugins show up
Only some plugins show up
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 11:42 EDT by Mary Ellen Foster
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 15:49:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of eclipse -debug -clean -consolelog from installation directory (828.01 KB, text/plain)
2012-05-29 08:17 EDT, Mary Ellen Foster
no flags Details
diff between working and non-working ~/.eclipse directory (7.24 MB, text/plain)
2012-05-29 08:18 EDT, Mary Ellen Foster
no flags Details

  None (edit)
Description Mary Ellen Foster 2012-05-28 11:42:46 EDT
Description of problem:
Since the update to Eclipse 4.2.0-0.22 on Friday (25 May), only some of the plugins seem active: that is, I can see editors, perspectives, and so on from JDT and from TeXlipse (for example), but nothing from CDT or fedorapackager. So if I click on a .h or a .spec file, it opens in an external editor.

Running with eclipse -clean -debug -consolelog, I see everything I should.

Version-Release number of selected component (if applicable):
1:eclipse-platform-4.2.0-0.22.I201205031800.fc17.x86_64

How reproducible:
Haven't tried -- but it happens every time I open Eclipse with this configuration

Additional info:

Here's a link to a zipped version of my ~/.eclipse directory:
http://www.macs.hw.ac.uk/~mef3/eclipse-backup-2012-05-28.tar.xz


Here's the output of rpm -qa eclipse*:

eclipse-cdt-8.1.0-0.10.junom7.fc17.x86_64
eclipse-changelog-2.7.0-7.fc17.noarch
eclipse-cmakeed-1.1.6-2.fc17.noarch
eclipse-color-theme-0.11.1-1.fc16.noarch
eclipse-dtp-1.10-0.1.M6.fc17.noarch
eclipse-egit-1.3.0-3.fc17.noarch
eclipse-emf-2.8.0-0.7.e674bb28ad412fc9bc786f2f9b3c157eb2cbdae0.fc17.noarch
eclipse-emf-core-2.8.0-0.22.I201205031800.fc17.x86_64
eclipse-emf-xsd-2.8.0-0.7.e674bb28ad412fc9bc786f2f9b3c157eb2cbdae0.fc17.noarch
eclipse-fedorapackager-0.3.2-4.fc17.noarch
eclipse-gef-3.8.0-0.3.20120402.fc17.noarch
eclipse-jdt-4.2.0-0.22.I201205031800.fc17.x86_64
eclipse-jgit-1.3.0-3.fc17.noarch
eclipse-pde-4.2.0-0.22.I201205031800.fc17.x86_64
eclipse-platform-4.2.0-0.22.I201205031800.fc17.x86_64
eclipse-rcp-4.2.0-0.22.I201205031800.fc17.x86_64
eclipse-rpm-editor-0.10.0-1.fc17.x86_64
eclipse-rpmstubby-0.10.0-1.20120402git2adb2a7.fc17.noarch
eclipse-rse-3.3.1-1.fc17.noarch
eclipse-slice2java-3.4.2.20111024-2.fc17.noarch
eclipse-subclipse-1.8.9-2.fc17.noarch
eclipse-svnkit-1.3.4-2.fc15.noarch
eclipse-swt-4.2.0-0.22.I201205031800.fc17.x86_64
eclipse-texlipse-1.5.0-1.20111125git254ca99.fc17.noarch
eclipse-vrapper-0.18.0-0.1.git1961d1.fc17.noarch
eclipse-wtp-common-3.4.0-0.1.20120425cvs.fc17.noarch
eclipse-wtp-sourceediting-3.4.0-0.1.M6.fc17.noarch
Comment 1 Krzysztof Daniel 2012-05-29 03:00:40 EDT
I'm looking into it.
Comment 2 Krzysztof Daniel 2012-05-29 03:14:48 EDT
Your .eclipse directory seems to be fine. 

I need a .log file that can be found in your workspace/.metadata directory after you start eclipse with -clean.

The other thing I need is an output of:
cd /usr/lib64/eclipse
eclipse -debug -clean -consolelog

It is necessary to start eclipse in the installation directory - it should give a really good dependencies resolution info.

Also, if you open a Plug-in Registry view, do you see cdt bundles loaded?

Is there anything else missing except the CDT?
Comment 3 Mary Ellen Foster 2012-05-29 08:15:32 EDT
(In reply to comment #2)
> Your .eclipse directory seems to be fine. 

However: yesterday, I tried "eclipse -debug -clean -consolelog" and today, when I loaded Eclipse, the plug-ins were there. Then I copied the attached .eclipse directory back into place and re-started eclipse, and the plugins were gone again. So something in that ~/.eclipse triggers badness.

> I need a .log file that can be found in your workspace/.metadata directory
> after you start eclipse with -clean.

Running with "-clean", I don't see the problem any more. Do you still want the log?

Also, it seems that just "-clean" is enough to fix the problem with my .eclipse. If I run eclipse -clean, close, and then run regular eclipse, the problem goes away.

I'll attach the diff between my working and non-working .eclipse directories shortly.

> The other thing I need is an output of:
> cd /usr/lib64/eclipse
> eclipse -debug -clean -consolelog
> 
> It is necessary to start eclipse in the installation directory - it should
> give a really good dependencies resolution info.

I'll attach that too.

> Also, if you open a Plug-in Registry view, do you see cdt bundles loaded?

No.

> Is there anything else missing except the CDT?

At least the eclipse-fedorapackager stuff is also missing
Comment 4 Mary Ellen Foster 2012-05-29 08:17:50 EDT
Created attachment 587393 [details]
Output of eclipse -debug -clean -consolelog from installation directory
Comment 5 Mary Ellen Foster 2012-05-29 08:18:45 EDT
Created attachment 587394 [details]
diff between working and non-working ~/.eclipse directory
Comment 6 Krzysztof Daniel 2012-05-29 13:19:56 EDT
Two issues here:

1. !MESSAGE Unable to satisfy dependency from org.fedoraproject.eclipse.packager.feature.feature.group 0.3.2.201205241628 to javax.xml.bind 0.0.0.
It might be a bug in the fedorapackager which does not symlink the javax.xml.bind. Could you install eclipse-mylyn-commons and check if the problem goes away?
If yes, I will open a separate bug for this issue.
  
2. Some problems seem to be caused by net.sourceforge.vrapper.eclipse. Could you check if uninstalling it helps? Also, running eclipse without -clean could help.
Comment 7 Mary Ellen Foster 2012-06-01 07:31:28 EDT
Neither installing eclipse-mylyn-commons nor uninstalling eclipse-vrapper have any effect on the symptoms. However, running eclipse -clean once seems to fix things up -- after running that one time and closing eclipse, then regular runs of eclipse (without -clean) also find all of the plug-ins again.

I can reproduce the problem at will by copying my old ~/.eclipse (linked above) back into place.
Comment 8 Krzysztof Daniel 2012-06-04 15:49:29 EDT
I'm afraid there is nothing I can do about this issue right now, as it is related to Equinox caching, and it is impossible to clean user configuration at install time.
Running eclipse -clean is  practically the only option that we have right now. I'll try to limit the number of future plugin content changes which are not reflected in the plugin version.

Note You need to log in before you can comment on or make changes to this bug.