Bug 825867 - Anaconda refuses to create a degenerate RAID-1
Anaconda refuses to create a degenerate RAID-1
Status: CLOSED DUPLICATE of bug 189316
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 15:30 EDT by H. Peter Anvin
Modified: 2012-05-29 06:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 06:56:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H. Peter Anvin 2012-05-28 15:30:14 EDT
Description of problem:
Anaconda insists a RAID device has to have more than one member.  This makes it impossible to create a single-member RAID-1 (effectively a single partition with a RAID superblock) with the intent of adding a second device later.

Version-Release number of selected component (if applicable):

Fedora 17 release media (version unknown).


How reproducible:

100%


Steps to Reproduce:
1. Try to install Fedora 17 on a system with only one drive, but create the filesystems as RAID-1, sans LVM.
2. Watch Anaconda try to tell you a RAID device must have two members, and therefore refuse.
  
Actual results:


Expected results:


Additional info:
Comment 1 Martin Sivák 2012-05-29 06:56:49 EDT
That is intentional behaviour. We do not support installing to degraded RAID.

See:

https://bugzilla.redhat.com/show_bug.cgi?id=688609
https://bugzilla.redhat.com/show_bug.cgi?id=435237
https://bugzilla.redhat.com/show_bug.cgi?id=189316

*** This bug has been marked as a duplicate of bug 189316 ***

Note You need to log in before you can comment on or make changes to this bug.