Bug 825906 - man pages are not up to date with 3.3.0 features/options.
man pages are not up to date with 3.3.0 features/options.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: unclassified (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity urgent
: ---
: ---
Assigned To: Kaushal
:
: 837578 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 23:34 EDT by Amar Tumballi
Modified: 2014-04-17 09:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 09:12:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2012-05-28 23:34:23 EDT
Description of problem:
Current man pages in release-3.3 branch (and even master branch) are not uptodate with latest features/options. 

Hence its better to remove them from the build for now in the release, so we would be giving sort of no information instead of 'wrong' information. Current plan is to fix man-pages and include it by 3.3.1 time frame.

Users can refer to documentation using Admin Guide/Release Notes for now.
Comment 1 Amar Tumballi 2012-05-31 06:09:39 EDT
Kaushal, we have to fix this sometime. Lets plan for 3.3.1 release timeframe. work on this during  break between other bugs, we can keep fixing one man page at a time.
Comment 2 Kaushal 2012-07-04 06:24:43 EDT
*** Bug 837578 has been marked as a duplicate of this bug. ***
Comment 3 Vijay Bellur 2012-10-11 13:37:08 EDT
CHANGE: http://review.gluster.org/4064 (build: Add glusterd man page packaging in buildspec) merged in release-3.3 by Vijay Bellur (vbellur@redhat.com)
Comment 4 Vijay Bellur 2012-10-12 02:02:26 EDT
CHANGE: http://review.gluster.org/4060 (glusterfs man page edit) merged in master by Anand Avati (avati@redhat.com)
Comment 5 Vijay Bellur 2012-10-12 08:10:46 EDT
CHANGE: http://review.gluster.org/4061 (glusterfs man page edit) merged in release-3.3 by Vijay Bellur (vbellur@redhat.com)
Comment 6 Anand Avati 2013-07-15 07:22:32 EDT
REVIEW: http://review.gluster.org/5329 (doc: release-notes for 3.4.0) posted (#1) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 7 Anand Avati 2013-07-15 09:36:53 EDT
COMMIT: http://review.gluster.org/5329 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit c25908538bd9d0c8b01d73f11f502829506a93e0
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Mon Jul 15 16:49:41 2013 +0530

    doc: release-notes for 3.4.0
    
    Change-Id: I8245e35198b9c5990fa70dea2b2b03e1c227e411
    BUG: 825906
    Reviewed-on: http://review.gluster.org/5329
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Vijay Bellur <vbellur@redhat.com>
Comment 8 Anand Avati 2013-08-12 12:40:36 EDT
REVIEW: http://review.gluster.org/5579 (doc: Update bug for replace-brick problems.) posted (#1) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 9 Anand Avati 2013-09-09 20:27:00 EDT
COMMIT: http://review.gluster.org/5579 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 8d31709041e098a7d508f43f4de9c854b88a8c2e
Author: Vijay Bellur <vbellur@redhat.com>
Date:   Mon Aug 12 22:08:36 2013 +0530

    doc: Update bug for replace-brick problems.
    
    Change-Id: I372568d86fe1b043504dd189853e156b2e210b6e
    BUG: 825906
    Signed-off-by: Vijay Bellur <vbellur@redhat.com>
    Reviewed-on: http://review.gluster.org/5579
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 11 Niels de Vos 2014-04-17 09:12:09 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.