Bug 825952 - after deleting the consumer, subscription-manager identity throws error "super() argument 1 must be type, not classobj"
after deleting the consumer, subscription-manager identity throws error "supe...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.9
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-05-29 03:47 EDT by Shwetha Kallesh
Modified: 2013-01-07 22:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:53:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2012-05-29 03:47:21 EDT
Description of problem:
after deleting the consumer, subscription-manager identity throws error "super() argument 1 must be type, not classobj"

Version-Release number of selected component (if applicable):

[root@dhcp201-111 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
subscription-manager-gnome-1.0.2-1.git.2.2b23e6e.el5
subscription-manager-migration-1.0.2-1.git.2.2b23e6e.el5
subscription-manager-firstboot-1.0.2-1.git.2.2b23e6e.el5
subscription-manager-1.0.2-1.git.2.2b23e6e.el5

How reproducible:


Steps to Reproduce:
[root@dhcp201-111 ~]# subscription-manager register --org=admin --force
Username: admin
Password: 
[root@dhcp201-111 ~]# subscription-manager register --consumerid=06be188e-cac1-4fa8-96a2-f94aea6766f6
This system is already registered. Use --force to override
[root@dhcp201-111 ~]# subscription-manager register --org=admin --force
Username: admin
Password: 
The system has been registered with id: e9c2a810-cc9d-4eee-a967-f2e873d20155 
[root@dhcp201-111 ~]# subscription-manager identity
Current identity is: e9c2a810-cc9d-4eee-a967-f2e873d20155
name: dhcp201-111.englab.pnq.redhat.com
org name: Admin Owner
org id: 8ac14934379332390137933252100002
[root@dhcp201-111 ~]# curl -k -u admin:admin --request DELETE https://10.65.201.180:8443/candlepin/consumers/e9c2a810-cc9d-4eee-a967-f2e873d20155
[root@dhcp201-111 ~]# subscription-manager identity
super() argument 1 must be type, not classobj

[root@dhcp201-111 ~]# subscription-manager list --avail
super() argument 1 must be type, not classobj

[root@dhcp201-111 ~]# tail -f /var/log/rhsm/rhsm.log
    return self.conn.request_get(method)
  File "/usr/lib/python2.4/site-packages/rhsm/connection.py", line 383, in request_get
    return self._request("GET", method)
  File "/usr/lib/python2.4/site-packages/rhsm/connection.py", line 345, in _request
    self.validateResponse(result)
  File "/usr/lib/python2.4/site-packages/rhsm/connection.py", line 367, in validateResponse
    parsed['displayMessage'], parsed['deletedId'])
  File "/usr/lib/python2.4/site-packages/rhsm/connection.py", line 84, in __init__
    super(GoneException, self).__init__(code, msg)
TypeError: super() argument 1 must be type, not classobj
2012-05-29 13:15:04,259 [DEBUG]  @connection.py:147 - ContectConnection
2012-05-29 13:15:04,264 [INFO]  @connection.py:481 - Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
2012-05-29 13:15:04,264 [INFO]  @connection.py:494 - Connection Built: host: 10.65.201.180, port: 8443, handler: /candlepin
2012-05-29 13:15:04,266 [INFO]  @cache.py:160 - Checking current system info against cache: /var/lib/rhsm/facts/facts.json
2012-05-29 13:15:04,366 [DEBUG]  @cert_sorter.py:106 - Sorting product and entitlement cert status for: 2012-05-29 07:45:04.366843+00:00
2012-05-29 13:15:04,368 [DEBUG]  @cert_sorter.py:160 - Installed product IDs: ['69']
2012-05-29 13:15:04,368 [DEBUG]  @cert_sorter.py:113 - valid entitled products: []
2012-05-29 13:15:04,369 [DEBUG]  @cert_sorter.py:114 - expired entitled products: []
2012-05-29 13:15:04,369 [DEBUG]  @cert_sorter.py:115 - partially entitled products: []
2012-05-29 13:15:04,369 [DEBUG]  @cert_sorter.py:116 - unentitled products: ['69']
2012-05-29 13:15:04,369 [DEBUG]  @cert_sorter.py:117 - future products: []
2012-05-29 13:15:04,369 [DEBUG]  @cert_sorter.py:118 - partial stacks: []
2012-05-29 13:15:04,369 [DEBUG]  @cert_sorter.py:119 - valid stacks: []
2012-05-29 13:15:04,369 [INFO]  @cache.py:175 - No changes.
2012-05-29 13:15:04,370 [DEBUG]  @connection.py:306 - Loading CA PEM certificates from: /etc/rhsm/ca/
2012-05-29 13:15:04,370 [DEBUG]  @connection.py:288 - Loading CA certificate: '/etc/rhsm/ca/candlepin-ca.pem'
2012-05-29 13:15:04,370 [DEBUG]  @connection.py:288 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2012-05-29 13:15:04,371 [DEBUG]  @connection.py:288 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2012-05-29 13:15:04,371 [DEBUG]  @connection.py:327 - Making request: GET /candlepin/
2012-05-29 13:15:04,387 [DEBUG]  @connection.py:340 - Response status: 410
2012-05-29 13:15:04,387 [ERROR]  @managercli.py:104 - exception caught in subscription-manager
2012-05-29 13:15:04,387 [ERROR]  @managercli.py:105 - super() argument 1 must be type, not classobj
Traceback (most recent call last):
  File "/usr/sbin/subscription-manager", line 79, in ?
    sys.exit(abs(main() or 0))
  File "/usr/sbin/subscription-manager", line 70, in main
    return managercli.CLI().main()
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1951, in main
    return cmd.main()
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 385, in main
    return_code = self._do_command()
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1715, in _do_command
    self.facts, self.options.all, on_date)
  File "/usr/share/rhsm/subscription_manager/managerlib.py", line 325, in getAvailableEntitlements
    dlist = list_pools(cpserver, consumer_uuid, facts, get_all, active_on)
  File "/usr/share/rhsm/subscription_manager/managerlib.py", line 300, in list_pools
    profile_mgr.update_check(uep, consumer_uuid)
  File "/usr/share/rhsm/subscription_manager/cache.py", line 214, in update_check
    if not uep.supports_resource(PACKAGES_RESOURCE):
  File "/usr/lib/python2.4/site-packages/rhsm/connection.py", line 521, in supports_resource
    self._load_supported_resources()
  File "/usr/lib/python2.4/site-packages/rhsm/connection.py", line 508, in _load_supported_resources
    resources_list = self.conn.request_get("/")
  File "/usr/lib/python2.4/site-packages/rhsm/connection.py", line 383, in request_get
    return self._request("GET", method)
  File "/usr/lib/python2.4/site-packages/rhsm/connection.py", line 345, in _request
    self.validateResponse(result)
  File "/usr/lib/python2.4/site-packages/rhsm/connection.py", line 367, in validateResponse
    parsed['displayMessage'], parsed['deletedId'])
  File "/usr/lib/python2.4/site-packages/rhsm/connection.py", line 84, in __init__
    super(GoneException, self).__init__(code, msg)
TypeError: super() argument 1 must be type, not classobj

  
Actual results:


Expected results:
Should say "Consumer e9c2a810-cc9d-4eee-a967-f2e873d20155 has been deleted"

Additional info:
Comment 1 Alex Wood 2012-06-28 13:02:32 EDT
commit 402137dc8f648285334dfa0be77d3d37e83dc37f
Refs: <origin/wottop/bug825952>, python-rhsm-1.0.2-1-4-g402137d
Author:     William Poteat <wpoteat@redhat.com>
AuthorDate: Thu Jun 21 14:24:26 2012 -0400
Commit:     William Poteat <wpoteat@redhat.com>
CommitDate: Fri Jun 22 08:01:13 2012 -0400

    825952: Error after deleting consumer at server

    super() not available in RHEL 5.9 python version.
Comment 2 RHEL Product and Program Management 2012-06-28 13:18:58 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Shwetha Kallesh 2012-07-02 05:09:43 EDT
Marking verified!!

RPM version:
[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-firstboot-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-migration-data-1.11.2.1-1.git.8.87961f3.el5
subscription-manager-gui-1.0.5-1.git.31.a3d5de2.el5


[root@dhcp201-196 ~]# subscription-manager register --org=admin --force
Username: admin
Password: 
The system has been registered with id: 85113695-162e-4c59-bd54-98aaf172b998 
[root@dhcp201-196 ~]# curl -k -u admin:admin --request DELETE https://10.65.201.132:8443/candlepin/consumers/85113695-162e-4c59-bd54-98aaf172b998

[root@dhcp201-196 ~]# subscription-manager identity
remote entitlement server type: RHN classic and subscription management service
Consumer 85113695-162e-4c59-bd54-98aaf172b998 has been deleted
Comment 5 errata-xmlrpc 2013-01-07 22:53:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.