Bug 825994 - RHEVM-Manage-Domains - manage-domains.log file always empty
RHEVM-Manage-Domains - manage-domains.log file always empty
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-config (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Yaniv Bronhaim
Pavel Stehlik
infra
:
: 836887 842676 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 05:44 EDT by Ortal
Modified: 2016-02-10 14:38 EST (History)
8 users (show)

See Also:
Fixed In Version: si15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:58:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ortal 2012-05-29 05:44:38 EDT
Description of problem:

RHEVM-Manage-Domains - manage-domains.log file always empty

Version-Release number of selected component (if applicable):
RHEVM 3.1 Version Si4

How reproducible:
Always

Steps to Reproduce:
1. Run rhevm-manage-domains command with an error, such as: do not add -provider flag
  
Actual results:

rhevm-manage-domains.log file stays empty though getting an error prints on screen.

[root@ortal-rhevm1 ~]#
[root@ortal-rhevm1 ~]# rhevm-manage-domains -action=add -domain=qa.lab.tlv.redhat.com -user=ortal -interactive -addPermissions -passwordFile=/tmp/.pwd
Argument provider is required.
[root@ortal-rhevm1 ~]# ls -l /var/log/engine/engine-manage-domains/engine-manage-domains.log
-rw-r--r--. 1 root root 0 May 29 12:32 /var/log/engine/engine-manage-domains/engine-manage-domains.log


Expected results:
The log file needs to be filled up.
+
We should think about changing the log file location to be with the rest of the ovirt logs, which means under: /var/log/ovirt-engine/*
Comment 1 Yaniv Bronhaim 2012-07-30 11:14:29 EDT
i've checked with si7, added new domain and the log is full.
the log is located in /var/log/engine/engine-manage-domains/engine-manage-domains.log, 

what about changing the file location? still relevant?
Comment 2 Yair Zaslavsky 2012-07-31 04:00:20 EDT
Yes, please change the log file location, by changing the log4j.xml file.
Please verify after fix that log collector collects the manage domains log.
Comment 3 Yair Zaslavsky 2012-08-01 07:53:43 EDT
*** Bug 842676 has been marked as a duplicate of this bug. ***
Comment 4 Yair Zaslavsky 2012-08-01 07:55:05 EDT
*** Bug 836887 has been marked as a duplicate of this bug. ***
Comment 5 Yaniv Bronhaim 2012-08-02 07:46:53 EDT
suggested patch: http://gerrit.ovirt.org/#/c/6855/
Comment 6 Yaniv Bronhaim 2012-08-02 09:03:04 EDT
gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=commit;h=19710f0e962baedffe7557ec9e0b5ffa8693d4db
Comment 14 Yair Zaslavsky 2012-08-12 03:52:02 EDT
Merged downstream -

https://gerrit.eng.lab.tlv.redhat.com/gitweb?p=ovirt-engine.git;a=commit;h=17beb5a89affb8fcfa1baec6aab4f9d91d428fbc


Log path is /var/log/ovirt-engine/engine-manage-domains.log

Note You need to log in before you can comment on or make changes to this bug.