Bug 826041 - Error: systemd conflicts with 1:nfs-utils-1.2.5-15.fc17.i686
Error: systemd conflicts with 1:nfs-utils-1.2.5-15.fc17.i686
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
17
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 09:00 EDT by Mark Einon
Modified: 2014-01-21 18:22 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-29 09:48:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Einon 2012-05-29 09:00:58 EDT
Description of problem:

Needed nfs-util -
Ran 'yum install nfs-utils'. 
The operation fails.

Version-Release number of selected component (if applicable):
# yum --version
3.4.3
  Installed: rpm-4.9.1.3-7.fc17.i686 at 2012-05-18 22:20
  Built    : Fedora Project at 2012-05-07 10:06
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2012-05-07

  Installed: yum-3.4.3-23.fc17.noarch at 2012-05-18 22:21
  Built    : Fedora Project at 2012-03-16 19:12
  Committed: James Antill <james at fedoraproject.org> at 2012-03-16


How reproducible:

Always

Steps to Reproduce:
1.At bash prompt with superuser privileges, run 'yum install nfs-utils'
2.Operation fails with a conflict error between systemd and nfs-utils.
3.
  
Actual results:
f# yum install nfs-utils
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package nfs-utils.i686 1:1.2.5-15.fc17 will be installed
--> Processing Dependency: libnfsidmap.so.0 for package: 1:nfs-utils-1.2.5-15.fc17.i686
--> Processing Dependency: libnfsidmap for package: 1:nfs-utils-1.2.5-15.fc17.i686
--> Running transaction check
---> Package libnfsidmap.i686 0:0.25-1.fc17 will be installed
--> Processing Conflict: systemd-44-12.fc17.i686 conflicts nfs-utils < 1:1.2.6
--> Finished Dependency Resolution
Error: systemd conflicts with 1:nfs-utils-1.2.5-15.fc17.i686
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

nfs-utils installed.

Additional info:
Comment 1 Panu Matilainen 2012-05-29 09:48:13 EDT
Since systemd conflicts with nfs-utils < 1:1.2.6, an older nfs-utils version cannot be installed. If yum would go ahead and try to install nfs-utils-1.2.5 despite the conflict, THAT would be a bug.
Comment 2 Mark Einon 2012-05-29 10:20:27 EDT
(In reply to comment #1)
> Since systemd conflicts with nfs-utils < 1:1.2.6, an older nfs-utils version
> cannot be installed. If yum would go ahead and try to install
> nfs-utils-1.2.5 despite the conflict, THAT would be a bug.

Ok, I think I've chosen the incorrect Component. I believe it should be 'rpm'.

This is still a valid issue that I believe needs resolving. Could it be re-opened as an rpm component issue?
Comment 3 Pytela, Zdenek 2012-05-29 10:45:13 EDT
nfs-utils version 1.2.6 is not available yet, systemd 44 is available, so I guess this is a bug.
When the nfs-utils package was installed already, yum update won't proceed and doesn't update any package even with --skip-broken.
Comment 4 Panu Matilainen 2012-05-30 01:23:23 EDT
Rpm is just as wrong component as yum is, both must honor conflicts when they are present.

The "bug" here is that a systemd update with insolvable dependencies has pushed out, and the only way to help it at this point is help getting the related nfs-utils update out.

Note You need to log in before you can comment on or make changes to this bug.