Bug 826233 - Building image from cli with a template without rootpw fails
Building image from cli with a template without rootpw fails
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: rubygem-aeolus-cli (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: 1.0.1
: ---
Assigned To: Mike Orazi
Shveta
: Rebase, Triaged, ZStream
Depends On: 804543
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 16:12 EDT by Chris Pelland
Modified: 2012-07-10 03:23 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The rootpw element in the component outline schema was set to optional, which caused image builds to fail. This update sets the rootpw element to mandatory. User now require the rootpw element in component outlines.
Story Points: ---
Clone Of: 804543
Environment:
Last Closed: 2012-07-10 03:23:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2012-05-29 16:12:54 EDT
+++ This bug was initially created as a clone of Bug #804543 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.[root@qe-blade-10 ~]# aeolus-image build --target ec2 --template fedora15.tpl -E default

ERROR:  Service Temporarily Unavailable => Please check that Conductor is running.

===========================================================
[root@qe-blade-10 ~]# aeolus-image build --target vsphere --template fedora15.tpl -E default
Image      Build       Target Image   Target      Status     
------------------------------------------------------------ 
fa2e9f2c-719d-11e1-aaee-00215e202f4e     4698a55a-8020-455e-bbfd-711a6c6898a4     a4fbbc04-ef7a-4ae2-8bad-91eb9573f580     vsphere     FAILED     

=================================================================
[root@qe-blade-10 ~]# aeolus-image build --target rhevm --template fedora15.tpl -E default
Image             Build       Target Image       Target     Status     
------------------------------------     -------------------------
034db246-719e-11e1-aaee-00215e202f4e     32aa133f-8bb3-4898-a35b-06656082a155     53d12221-62b4-47bd-84e3-756f4e4ce0b4     rhevm      FAILED     

=========================================================
2. Template used 
<?xml version="1.0"?>
<template>
  <name>Fedora 15</name>
  <description>desc</description>
  <os>
    <name>Fedora</name>
    <arch>x86_64</arch>
    <version>15</version>
    <install type="url">
      <url>http://download.fedoraproject.org/pub/fedora/linux/releases/15/Fedora/x86_64/os/</url>
    </install>
  </os>
  <repositories>
    <repository name="custom">
      <url>http://repos.fedorapeople.org/repos/aeolus/demo/webapp/</url>
      <signed>false</signed>
    </repository>
  </repositories>
</template>

3.
  
Actual results:


Expected results:


Additional info:

 rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.0-14.el6.noarch
aeolus-conductor-doc-0.8.0-43.el6.noarch
aeolus-conductor-0.8.0-43.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
aeolus-conductor-daemons-0.8.0-43.el6.noarch
aeolus-all-0.8.0-43.el6.noarch

--- Additional comment from ssachdev@redhat.com on 2012-03-19 04:37:05 EDT ---

Regression of 

https://bugzilla.redhat.com/show_bug.cgi?id=761200

https://bugzilla.redhat.com/show_bug.cgi?id=761139

--- Additional comment from hbrock@redhat.com on 2012-03-19 14:12:19 EDT ---

We should fix this, but we are out of time for 1.0. Pushing to 1.0.z.

--- Additional comment from whayutin@redhat.com on 2012-04-30 11:24:42 EDT ---

The error message should be fixed for z stream

--- Additional comment from mtaylor@redhat.com on 2012-05-23 14:23:44 EDT ---

Conductor

commit 290dde45cfba2254aafd5c59b83f66e5d00f08ca
Author: Maros Zatko <mzatko@redhat.com>
Date:   Tue May 22 21:22:12 2012 +0200

    BZ804543: template relaxng: make rootpw mandatory
    
    rootpw tag is mandatory in imagefactory's xsd file

Aeolus CLI

commit 396a329b43764afa967778c33c71e9cab3843798
Author: Martyn Taylor <mtaylor@redhat.com>
Date:   Wed May 23 19:13:58 2012 +0100

    BZ804543 Removed Optional Element for rootpw in tdl
Comment 2 Dan Macpherson 2012-06-06 21:37:06 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The rootpw element in the component outline schema was set to optional, which caused image builds to fail. This update sets the rootpw element to mandatory. Ensure to include the rootpw element in component outlines.
Comment 3 Dan Macpherson 2012-06-06 21:38:19 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-The rootpw element in the component outline schema was set to optional, which caused image builds to fail. This update sets the rootpw element to mandatory. Ensure to include the rootpw element in component outlines.+The rootpw element in the component outline schema was set to optional, which caused image builds to fail. This update sets the rootpw element to mandatory. User now require the rootpw element in component outlines.
Comment 4 Aziza Karol 2012-06-07 00:41:13 EDT
The rootpw element in the component outline schema is mandatory now.
if rootpw is missing in the template following message is displayed:

#aeolus-image build --target ec2 --template fedora15.tpl -E default
ERROR: The given Template does not conform to the TDL Schema, see below for specific details:
- Line: 5 => Expecting an element rootpw, got nothing
- Line: 5 => Invalid sequence in interleave
- Line: 5 => Element os failed to validate content


verified on:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.27-1.el6_3.noarch
aeolus-conductor-doc-0.8.27-1.el6_3.noarch
aeolus-conductor-daemons-0.8.27-1.el6_3.noarch
aeolus-conductor-0.8.27-1.el6_3.noarch
aeolus-configure-2.5.7-1.el6_3.noarch
rubygem-aeolus-cli-0.3.3-1.el6_3.noarch
Comment 6 errata-xmlrpc 2012-07-10 03:23:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1063.html

Note You need to log in before you can comment on or make changes to this bug.