Bug 826268 - ValueError: Cannot remove non-leaf device 'vg_orthanc_ssd-root_fs'
ValueError: Cannot remove non-leaf device 'vg_orthanc_ssd-root_fs'
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:9b2cc139d65041ea5c504b92238...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 17:36 EDT by David Mansfield
Modified: 2012-05-31 11:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 11:34:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-d9llDn (654.84 KB, text/plain)
2012-05-29 17:36 EDT, David Mansfield
no flags Details

  None (edit)
Description David Mansfield 2012-05-29 17:36:21 EDT
libreport version: 2.0.10
cmdline:        /usr/bin/python  /usr/sbin/anaconda
executable:     /usr/sbin/anaconda
exnFileName:    /tmp/anaconda-tb-d9llDn
hashmarkername: anaconda
kernel:         3.3.4-5.fc17.x86_64
other involved packages: 
product:        Fedora
release:        Cannot get release name.
time:           Tue 29 May 2012 05:35:29 PM EDT
version:        17

anaconda-tb-d9llDn: Text file, 670557 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.29 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 370, in _removeDevice
:    raise ValueError("Cannot remove non-leaf device '%s'" % dev.name)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 420, in registerAction
:    self._removeDevice(action.device)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1748, in editLVMVolumeGroup
:    self.storage.devicetree.registerAction(action)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1666, in editCB
:    self.editLVMVolumeGroup(device)
:ValueError: Cannot remove non-leaf device 'vg_orthanc_ssd-root_fs'

environ:
:LANG=en_US.UTF-8
:LC_NUMERIC=C
:TERM=linux
:BOOT_IMAGE=vmlinuz
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:PYTHONPATH=/tmp/updates
:PWD=/
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBUSER_CONF=/tmp/libuser.5YnzfS
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=initrd.img
:MALLOC_PERTURB_=204
:TZ=America/New_York
:GCONF_GLOBAL_LOCKS=1
:HOME=/tmp
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:PATH=/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:MALLOC_CHECK_=2
:DISPLAY=:1
Comment 1 David Mansfield 2012-05-29 17:36:25 EDT
Created attachment 587534 [details]
File: anaconda-tb-d9llDn
Comment 2 David Mansfield 2012-05-29 18:12:01 EDT
This is an installer crash.  It's reproducible. I cannot install F17 due to this bug.

Scenario:

I want to install a fresh F17 in an existing system.  I have many LV on 2 VG.  I also have a partition /dev/sda1 for /boot.

I'd like to re-format and install onto 3 LV (on different VG) plus the /boot partition, and mount some of the others.  The mounting can be deferred to later, assuming I can get past this bug.

The LV in question are currently formatted btrfs via the F16 (or F15, can't remember) installer.  Some of the other LV are also btrfs.

When selecting them in the "edit vg" menu, I cannot choose to re-format the LV, the option is grayed out.  Also, I tried deleting the LV and re-adding with a different FS-type.  Resulted in "same" crash (I say same because I don't have the traceback of both).

Seems probably a bug because btrfs doesn't seem to be a valid "fs type" in this release.
Comment 3 David Lehman 2012-05-30 12:10:00 EDT
Unfortunately, we had to temporarily reduce our support for btrfs in F17 due to some resource constraints and upstream work planned for F18. In F18 you will see a completely new user interface for the installer, including full support for all of the major btrfs features like subvolumes and RAID. Sorry for the inconvenience.

In the meantime, see https://fedoraproject.org/wiki/Anaconda/Kickstart#btrfs for the only way to use btrfs in F17: kickstart.
Comment 4 David Mansfield 2012-05-31 11:33:36 EDT
I was able to complete an installation as long as no LV that contained BTRFS was "touched" during installation, e.g. I did not remove, reformat or mount any of them, just installed on new LV in the same VG.
Comment 5 David Mansfield 2012-05-31 11:34:10 EDT
assuming it won't be fixed and marking appropriately.

Note You need to log in before you can comment on or make changes to this bug.