Bug 826279 - grub2 selects wrong video refresh rate for ATI Radeon 5500 (REDWOOD) card
grub2 selects wrong video refresh rate for ATI Radeon 5500 (REDWOOD) card
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
x86_64 All
unspecified Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 18:12 EDT by G.Wolfe Woodbury
Modified: 2012-11-13 12:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 12:15:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
probed EDID info for monitor from Xorg.0.log (6.59 KB, text/plain)
2012-05-29 18:12 EDT, G.Wolfe Woodbury
no flags Details
Xorg.0.log of running system (55.89 KB, text/plain)
2012-05-29 19:07 EDT, G.Wolfe Woodbury
no flags Details
non-quiet dmesg output from kernel-3.3.7 (x86_64) (71.56 KB, text/plain)
2012-05-29 19:08 EDT, G.Wolfe Woodbury
no flags Details
Possible fix (2.38 KB, patch)
2012-06-02 08:58 EDT, Vladimir Serbinenko
no flags Details | Diff

  None (edit)
Description G.Wolfe Woodbury 2012-05-29 18:12:52 EDT
Created attachment 587544 [details]
probed EDID info for monitor from Xorg.0.log

Description of problem:
  GRUB2_GFXMODE=auto selects an invalid mode for the ATU Radeon 5500 and monitor combo.  Setting to 1024x768 works.


Version-Release number of selected component (if applicable):
  grub2-2.0-0.25.beta4.fc17

How reproducible:
  always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
  monitor is overdriven because the "wrong" sync frequency is selected.

Expected results:
  normal display

Additional info:
LSPCI:
01:00.0 VGA compatible controller: ATI Technologies Inc Redwood PRO [Radeon HD 5500 Series]

extract of Xorg.0.log attached showing EDID info from monitor:
   (Hannspree 1600x900 LCD flat panel)
Comment 1 Mads Kiilerich 2012-05-29 18:16:47 EDT
Do explicitly setting 1600x900 work?
Comment 2 G.Wolfe Woodbury 2012-05-29 18:43:43 EDT
swttung 1600x900 fails

1280x1024 works (from Xorg.0.log probed modes)

anything higher seems to overdrive the monitor.  Still testing combinations.
Comment 3 G.Wolfe Woodbury 2012-05-29 19:05:45 EDT
Anything greater than 1280x<N> makes grub2 overdrive the monitor.

Attaching Xorg.0.log  and non-quiet dmesg output from kernel-3.3.7
Comment 4 G.Wolfe Woodbury 2012-05-29 19:07:11 EDT
Created attachment 587554 [details]
Xorg.0.log of running system
Comment 5 G.Wolfe Woodbury 2012-05-29 19:08:51 EDT
Created attachment 587555 [details]
non-quiet dmesg output from kernel-3.3.7 (x86_64)
Comment 6 Mads Kiilerich 2012-05-29 19:26:16 EDT
Hmm. Yeah.

The kernel vesafb do for some reason use 1280x960x32.

What resolution do X use? It seems like it uses 1600x900 - does that work?
Comment 7 G.Wolfe Woodbury 2012-05-29 23:50:54 EDT
Yes, the X server uses the 1600x900 mode (as does a gentoo kernel that has 1600x900 buikt into the kernel)
Comment 8 Mads Kiilerich 2012-05-30 08:39:10 EDT
So the resolution is ok - it is just 'something else' that is wrong.

Can you show a photo of the bad graphic?
Comment 9 G.Wolfe Woodbury 2012-05-30 15:10:10 EDT
The monitor displays a "signal out of range" message

grub2 is selecting too high a refresh rate compared to the KMS and Xorg server.
Comment 10 Mads Kiilerich 2012-05-31 07:59:30 EDT
What is the output of
  set pager=1
  videoinfo
on the grub command line?
Comment 11 G.Wolfe Woodbury 2012-06-01 07:25:55 EDT
The videoinfo dump gives lots of "modeline"-like entries for the VBE type adapter.

It does not detect a "VGA". Cirrus or anything other than the VBE adapter.

I not that many of the modes it lists are inappropriate for the particular monitor being used.  

BTW is there a way to capture the output into a file or something?  I have no cameras to capture the output.
Comment 12 Vladimir Serbinenko 2012-06-02 08:58:07 EDT
Created attachment 588659 [details]
Possible fix

Could you try this patch?
Comment 13 Mads Kiilerich 2012-06-02 14:49:24 EDT
The patch is included in the unofficial beta6 scratch build on http://koji.fedoraproject.org/koji/taskinfo?taskID=4121699

Install grub2 and grub2-tools rpms,
grub2-install /dev/sda
grub2-mkconfig -o /boot/grub2/grub.cfg
Comment 14 G.Wolfe Woodbury 2012-06-03 08:21:35 EDT
Downloaded, will test
Comment 15 G.Wolfe Woodbury 2012-06-03 08:21:35 EDT
Downloaded, will test
Comment 16 G.Wolfe Woodbury 2012-06-03 08:22:17 EDT
Downloaded, will test
Comment 17 G.Wolfe Woodbury 2012-06-03 09:04:31 EDT
tested...
It works with gfxmode=auto
Comment 18 Mads Kiilerich 2012-06-03 09:27:27 EDT
(In reply to comment #17)

> It works with gfxmode=auto

Cool. This is the (implicit) default, so this grub version should work out of the box on existing installations without any /etc/default/grub changes. Do you agree?
Comment 19 G.Wolfe Woodbury 2012-06-03 16:06:47 EDT
Yes, it seems to be working for me.
I look forward to seeing it in updates-testing.
Comment 20 G.Wolfe Woodbury 2012-11-13 12:15:29 EST
now irrelevant, was fixed by the actions shown above
closing: currentrelease

Note You need to log in before you can comment on or make changes to this bug.